Implement Basic Context Menu in Panorama

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
P4
enhancement
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: Ryuji, Unassigned)

Tracking

unspecified
Future
Dependency tree / graph

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre

Ideally if possible, allowing basic tab functions such as reload tab, bookmark this tab, Make into App Tab, Undo Close Tab, etc should be allowed in Tab View of Tab Candy. 

This fundamental function make Tab Candy a lot more user-friendly and allows users to perform various tab action easier.

Reproducible: Always
(Reporter)

Updated

7 years ago
Blocks: 585689
Summary: Allow Basic Tab Functions Like "Reload Tab" and "Make Tab into App Tab" in Tab Candy → Allow Tabs in Tab View to perform Basic Tab Functions Like "Reload Tab" and "Make Tab into App Tab"
(Reporter)

Updated

7 years ago
Depends on: 578553
Status: UNCONFIRMED → NEW
Ever confirmed: true
This could be a good candidate for what to put in the context menu (bug 590251).
Depends on: 590251
OS: Windows 7 → All
Priority: -- → P4
Hardware: x86 → All

Updated

7 years ago
Target Milestone: --- → Future
(Reporter)

Updated

7 years ago
Summary: Allow Tabs in Tab View to perform Basic Tab Functions Like "Reload Tab" and "Make Tab into App Tab" → Allow Tabs in Panorama to perform Basic Tab Functions Like "Reload Tab" and "Pin as App Tab"
This bug has been marked as "future" (post-ff4.0) but it still blocked our ff4.0 milestone bug; removing blocking.
No longer blocks: 585689

Comment 3

7 years ago
In addition to bookmarking a tab, it would be nice to have a "bookmark all tabs" option on a group.
Blocks: 590251
No longer depends on: 590251
(Reporter)

Comment 4

6 years ago
Context menu should include something like "bookmark group", "Reload Group"

Please give more ideas... Hopefully this can be implemented in Firefox 10
Summary: Allow Tabs in Panorama to perform Basic Tab Functions Like "Reload Tab" and "Pin as App Tab" → Implement Basic Context Menu in Panorama
Shall we use the context menus like below

For tab:
---------
Reload Tab
Bookmark Tab
---------
Pin as App Tab
Move to New Window
---------
Close Other Tabs
---------
Undo Close Tab  <- Will add this later because we need to implement a way to undo close tab in a group (bug 587874) 
Close Tab
---------

For group: 
---------
Reload Group
Bookmark Group
Close Group
---------

Updated

6 years ago
Depends on: 757012

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.