If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsslowhash.h missing from dist/public/nss

RESOLVED FIXED in 3.12.8

Status

NSS
Build
P1
critical
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Elio Maldonado, Assigned: Elio Maldonado)

Tracking

(Blocks: 1 bug)

3.12.7
3.12.8
All
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
nsslowhash.h doesn't get istalled in dist/public/nss. This header is needed to build softoken in Fedora and RHEL.
(Assignee)

Updated

7 years ago
Severity: normal → critical
Priority: -- → P1
See Also: → bug 497251
(Assignee)

Updated

7 years ago
Assignee: nobody → wtc
(Assignee)

Updated

7 years ago
Hardware: x86_64 → All
Target Milestone: --- → 3.12.8
Version: 3.12.7 → 3.12.8
(Assignee)

Comment 1

7 years ago
I built with FREEBL_NO_DEPEND=1; gmake nss_build_all as required.
(Assignee)

Comment 2

7 years ago
These lines that in 3.12.6 where in freebl/manifest.mn

ifdef FREEBL_NO_DEPEND
LOWHASH_SRCS = stubs.c nsslowhash.c
LOWHASH_EXPORTS = nsslowhash.h
MAPFILE_SOURCE = freebl_hash.def
else
MAPFILE_SOURCE = freebl.def
endif

now reside in freebl/config.mk

......
# only do this in the outermost freebl build.
ifndef FREEBL_CHILD_BUILD
<<< ommitted>>
else

ifeq ($(FREEBL_NO_DEPEND),1)
LOWHASH_SRCS = stubs.c nsslowhash.c
LOWHASH_EXPORTS = nsslowhash.h
MAPFILE_SOURCE = freebl_hash.def
else
MAPFILE_SOURCE = freebl.def
endif

# This is a recursive child make. We build the shared lib.
....

The changes for FREEBL_NO_DEPEND are in the else part.

It seems to me that when these lines where in manifest.mn the FREEBL_NO_DEPEND condition be testing up regardless of whether it was child build or not. I'm not yet saavy enough about the build system. Don't weneed these when building the freebl.a as well?
(Assignee)

Updated

7 years ago
Assignee: wtc → emaldona
Status: NEW → ASSIGNED

Comment 3

7 years ago
Created attachment 466700 [details] [diff] [review]
Proposed patch

Thanks for the bug report.  The problem is that in
lib/freebl/Makefile, only the 'release_md' and 'libs'
makefile targets are executed with FREEBL_CHILD_BUILD=1.
So the 'export' makefile target is executed with
FREEBL_CHILD_BUILD not defined.  This means we must
define LOWHASH_EXPORTS when FREEBL_CHILD_BUILD is not
defined.

So we can move that block of code to a few possible
places as long as it is not inside ifdef FREEBL_CHILD_BUILD.
In this patch I move it to lib/freebl/Makefile, merging
with an existing ifeq ($(FREEBL_NO_DEPEND),1) block.
(It's not clear which code belongs in lib/freebl/config.mk
or lib/freebl/Makefile...)
Attachment #466700 - Flags: review?(emaldona)

Comment 4

7 years ago
This bug was introduced in NSS 3.12.7 (bug 497251).
Version: 3.12.8 → 3.12.7
(Assignee)

Comment 5

7 years ago
(In reply to comment #3)

> So we can move that block of code to a few possible
> places as long as it is not inside ifdef FREEBL_CHILD_BUILD.
I was testing one patch where I moved it to the top config.mk, the header showed up.

> In this patch I move it to lib/freebl/Makefile, merging
> with an existing ifeq ($(FREEBL_NO_DEPEND),1) block.
Let me test it.

> (It's not clear which code belongs in lib/freebl/config.mk
> or lib/freebl/Makefile...)
Another place I thought of was in manifest.mn. I'm unclear about the proper place also.
(Assignee)

Comment 6

7 years ago
(In reply to comment #4)
> This bug was introduced in NSS 3.12.7 (bug 497251).
The thread was so long that at some point I took my eyes off. And this time I missed taking it for a spin downstream with the fedora build system during beta.

Comment 7

7 years ago
That block of code also must be after we have included security/coreconf/config.mk.
This is why I moved it out of manifest.mn (manifest is included before
security/coreconf/config.mk is included).

That block of code tests the FREEBL_NO_DEPEND variable, which we now define in
security/coreconf/Linux.mk, included by security/coreconf/config.mk.

Updated

7 years ago
Depends on: 497251

Updated

7 years ago
See Also: bug 497251
(Assignee)

Comment 8

7 years ago
Comment on attachment 466700 [details] [diff] [review]
Proposed patch

r+ from me. Ran all.sh and all tests passed - on the trunk.
Attachment #466700 - Flags: review?(emaldona) → review+
(Assignee)

Comment 9

7 years ago
Created attachment 466804 [details] [diff] [review]
Version for NSS_3_12_BRANCH

all.sh passes on NSS_3_12_BRANCH.
Attachment #466804 - Flags: review?(wtc)

Comment 10

7 years ago
Comment on attachment 466804 [details] [diff] [review]
Version for NSS_3_12_BRANCH

r=wtc.  Please check this in on the trunk and
NSS_3_12_BRANCH.  Thanks.
Attachment #466804 - Flags: review?(wtc) → review+
(Assignee)

Updated

7 years ago
Blocks: 544289
(Assignee)

Comment 11

7 years ago
I checked in to trunk
Checking in Makefile;
/cvsroot/mozilla/security/nss/lib/freebl/Makefile,v  <--  Makefile
new revision: 1.115; previous revision: 1.114
done
Checking in config.mk;
/cvsroot/mozilla/security/nss/lib/freebl/config.mk,v  <--  config.mk
new revision: 1.27; previous revision: 1.26
done

Branch next.
(Assignee)

Comment 12

7 years ago
Checked in patch for NSS_3_12_BRANCH
Checking in Makefile;
/cvsroot/mozilla/security/nss/lib/freebl/Makefile,v  <--  Makefile
new revision: 1.113.2.1; previous revision: 1.113
done
Checking in config.mk;
/cvsroot/mozilla/security/nss/lib/freebl/config.mk,v  <--  config.mk
new revision: 1.26.2.1; previous revision: 1.26
done

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.