Closed Bug 588135 Opened 9 years ago Closed 9 years ago

Fennec - Cannot submit forms

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(fennec2.0a1+)

VERIFIED FIXED
Tracking Status
fennec 2.0a1+ ---

People

(Reporter: naginenis, Assigned: stechz)

Details

Attachments

(1 file)

Sources:
mozilla-central: 50732:2dbb1278a15c
Mobile: 1801:4352b9348dea

Reproducible: Always

Steps to reproduce the issue:
1. Start Fennec
2. Open www.google.com
2. Close tab
5. Open www.youtube.com
6. Type "fennec" in YouTube's search field 
7. Tap on Youtube's search button

Actual Results:  
Nothing happens when trying to submit.

I see the following JS error in the console:
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /mozilla-central/content/html/content/src/nsHTMLFormElement.cpp, line 937
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMHTMLFormElement.submit]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: http://www.youtube.com/ :: onclick :: line 1"  data: no]
tracking-fennec: --- → ?
Seems to be a problem when the "formsubmmit", "earlyformsubmit" is fired:
http://mxr.mozilla.org/mozilla-central/source/content/html/content/src/nsHTMLFormElement.cpp#933

that could mean: forms.js, LoginManagerChild.js or formSubmitListener.js (in toolkit)
Assignee: nobody → webapps
Attached patch FixSplinter Review
The earlyformsubmit listeners were never getting removed!  I also wrapped notify in a try/catch block to make sure we catch any errors so the form always submits.
Attachment #466803 - Flags: review?(mark.finkle)
CC'ing dolske
Attachment #466803 - Flags: review?(mark.finkle) → review+
tracking-fennec: ? → 2.0a1+
pushed:
http://hg.mozilla.org/mobile-browser/rev/c27906ee1e1e
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
This issue is verified as fixed on Verified on Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110919 Firefox/9.0a1 Fennec/9.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.