Closed Bug 588283 Opened 9 years ago Closed 9 years ago

Pause before opening an e-mail

Categories

(Thunderbird :: Message Reader UI, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 599119

People

(Reporter: mail, Unassigned)

Details

(Keywords: perf)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.8) Gecko/20100802 Thunderbird/3.1.2

On a reasonably fast computer (Intel Core2 6300 @ 1.86GHz, 2 GB RAM), Thunderbird pauses for around 3-4 seconds(!) when opening any e-mail message. This did not happen with any 2.x version, and it does not happen on the other four Windows XP computers we tried it on.

This is independent of the content of the mail - tiny plain-text only mails take just as long as larger, HTML-formatted mails with multiple attachments. It happens also in Safe-Mode. It happens on IMAP mailboxes (connection to IMAP server over 1GBit/s low-latency link), and it also happens when the e-mail is in a local folder. It happens when showing the preview/message pane, and it happens when it's disabled. The Thunderbird profile was newly created by TB 3.1.2, no extensions installed.

When clicking on a mail, Thunderbird seems to freeze for 3-4 seconds, you can move the mouse, but everything else within the window is dead. Clicking on a menu within this time does not have any effect. Then, after that delay, 'Loading message...' appears in the status bar for a very short time, and then the mail gets shown. The menu you clicked on suddenly appears.

I will attach a log, that I created with 'depends.exe'. Scroll down to the bottom, where I inserted comments on what I was doing and seeing.

Reproducible: Always

Steps to Reproduce:
1. Install TB3.x on this particular computer ;)
2. Click on any e-mail

Actual Results:  
There is a delay of 3-4 seconds before the e-mail appears.

Expected Results:  
A delay of 0.1 to 0.5 seconds, at most.
So let see :

Did you try to start Tb in safemode ?
Any anti-virus running on that particular machine ?
Keywords: perf
Component: General → Message Reader UI
QA Contact: general → message-reader
(In reply to comment #2)
> So let see :
> 
> Did you try to start Tb in safemode ?
> Any anti-virus running on that particular machine ?

Sorry, I thought I had written that... yes, I tried running it with the -safe-mode parameter, no change. I also uninstalled two plugins that showed up in the depends.exe output (Windows Media Player plugin, Java), again with no change.

Anti-virus (Avira) is installed and usually running, I disabled it for testing once though, and it didn't change anything. The other four XP machines all run that anti-virus application as well, and there is no delay.
Version: unspecified → 3.1
Issue might be because of huge mailboxes, are you accessing the same accounts from all machines or are is the account on the slow machine more special ?

Wayne do we have some docs somewhere on profiling TB ?
The same IMAP account on all machines I tried. Some machines are considerably older/slower, and still they don't show the delay. Btw., I also tried a newly created profile without any mail server specified, just testing in Local Folders, and the delays were there.
Does setting plugin.scan.plid.all to false in the config editor solve your
problem? If it does, this bug is a duplicate of bug 599119.
That's it! Setting plugin.scan.plid.all to false makes Thunderbird on this box fast as it should be.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599119
You need to log in before you can comment on or make changes to this bug.