bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Add feature to select folder for each download with filename and extension copying

RESOLVED DUPLICATE of bug 360562

Status

Camino Graveyard
Downloading
--
enhancement
RESOLVED DUPLICATE of bug 360562
8 years ago
8 years ago

People

(Reporter: Bob Frost, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (like Firefox/3.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (like Firefox/3.0.19)

Option to manually select download location for each download, click on filename in the file save dialog pane to create a title which can be modified, including the file suffix (Firefox used to do this, no it does not). Camino sticks all downloads in one selected folder, no filenaming assistance. 

Eg: Bank Statements
Statement 2010 01,csv
Statement 2010 02,csv
Statement 2010 03,csv
Statement 2010 04,csv etc, requires changing only the month digits. Banks don't refine the titles of downloads based on selection period. 

Different folders for different file titling requirements would be handy.

Reproducible: Always

Comment 1

8 years ago
Pretty sure this is a dupe of bug 360562.
(Reporter)

Comment 2

8 years ago
Terrific, it's unclear whether Camino can do this already or if somewhere a decision was made to eliminate the convenience the option would provide. Or bot, or something else.

It's a deal killer for me. The way Camino download options are now makes extra work renaming and relocating downloaded files. PIA.

Comment 3

8 years ago
It already works; please read through the entire other bug to be sure that's what you're asking for (but it definitely sounds like it is).
(Reporter)

Comment 4

8 years ago
Chris, the alternatives for "Save downloaded files to:" are the "Downloads" folder or any other single folder selected in the browser drop down. I can "Select" another folder and downloads will go to that folder every time I download until I change the folder.

The opportunity to change to folder for each download event does not occur, neither does the opportunity arise to rename or click an existing file to get a head start on renaming the current download.

Maybe I'm just dense, but the bug 360562 has no instruction I can find to make it work as you claim it already does. The hidden preferences have nothing that addresses this problem. Help me out here, please. What am I missing?

Comment 5

8 years ago
Comment 9 and 10 in the other bug.
(Reporter)

Comment 6

8 years ago
If you are referring to: "Set browser.download.autoDownload to false." and by "the other bug" you mean bug 360562, what gets me to a location where I can make the change?

Comment 7

8 years ago
1. the pref has been renamed since bug 360562 (see bug 407883). It is now 'browser.download.useDownloadDir'

2. to modify the pref, type 'about:config' in the location bar, search for  'browser.download.useDownloadDir' and double click to toggle (or right-click on the pref and select toggle).
(Reporter)

Comment 8

8 years ago
wonderful. Where is the location bar. Do I search in a finder window?
(Reporter)

Comment 9

8 years ago
This thread might as well be in Martian. So far references and instrux have been among the most ambiguous and without context that I've ever experienced.

What application do I have to have and what do I have to do to find "location bar".

I am not a code savvy person but I am a power USER. How do I turn on the features that are, according to this thread, present in Camino? They are inaccessible by way of usual and customary browser preference settings as far as I can tell.
The location bar is that text field in the browser toolbar where the internet location (URL) is displayed and can be edited.
(Reporter)

Comment 11

8 years ago
OK. Thanks, I wondered about that.

Now, what do I paste in the location bar?

This: "browser.download.useDownloadDir" gives "Address not found".

This: "camino.download.useDownloadDir" lands on a search page with the message: "Sorry, we can't find "camino.download.usedownloaddir". We suggest that you check the spelling of the web address or search above."

I need a decoder ring. This is way more trouble than even using IE for the Mac.
(In reply to comment #7)
> 2. to modify the pref, type 'about:config' in the location bar, search for 
> 'browser.download.useDownloadDir' and double click to toggle (or right-click on
> the pref and select toggle).

If you need additional assistance, please visit the support forum at http://forums.mozillazine.org/viewforum.php?f=12 and start a new topic there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 360562
(Reporter)

Comment 13

8 years ago
Perfecto! Exactly the instruction I needed. Many thanks, Smokey!

The click-on-file-name behaves like Firefox and does not pick up the file suffix. Too bad, I guess. Gotta type three characters to replace an existing file, more to modify a filename to an evolution, like last month to this month. I'll live with it.
You need to log in before you can comment on or make changes to this bug.