Closed Bug 588379 Opened 11 years ago Closed 11 years ago

Errors in the Web Console should link to the source file

Categories

(DevTools :: General, defect, P1)

defect

Tracking

(blocking2.0 betaN+)

RESOLVED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: dangoor, Assigned: pcwalton)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Right now, when an error is displayed, the source file is listed but is not a link to view that file as it is in the Error Console.
Duplicate of this bug: 585553
Whiteboard: [kd4b5] → [kd4b7]
Whiteboard: [kd4b7]
This is one of the bugs that is forcing me to continue using the old error console.
This looks like a super-easy fix, the only question is: what is the best way to access the "viewSourceUtils"? http://mxr.mozilla.org/mozilla-central/source/toolkit/components/viewsource/content/viewSourceUtils.js

Do you just #include it at the end of HUDService.js? (Since we build our UI on the fly)

It is included via a script tag in the existing console.xul.
We could add an EXPORTED_SYMBOLS to viewSourceUtils and make it a jsm in the makefile, then just lazily load it.
Assignee: nobody → ddahl
Blocks: devtools4b8
This is one of the bits of functionality that will bring us up closer to par with the existing JS Error console. Needs blocking status.
blocking2.0: --- → ?
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
blocking2.0: ? → betaN+
Attached patch v 0.0 WIPSplinter Review
Saving work
Reassigning this to Patrick, because he's rejiggering the log output as it is.
Assignee: ddahl → pwalton
(In reply to comment #8)
> Reassigning this to Patrick, because he's rejiggering the log output as it is.

the WIP patch here is everything but the event handler for the output:) cool.
Marking bug 605621 as a dependency. The work here should build off that bug.
Depends on: 605621
Status: NEW → ASSIGNED
Depends on: 611506
This is fixed in my patch queue for bug 605621.
mass change: filter on PRIORITYSETTING
Priority: -- → P1
mass change: filter on PRIORITYSETTING
Blocks: devtools4
mass change: filter mail on BLOCKERSETTING
Severity: normal → blocker
Severity: blocker → normal
fixed by checkin from bug 605621
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.