All users were logged out of Bugzilla on October 13th, 2018

Forum asks to log-in when I'm logged in already

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: atopal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
In the new forums (support and contributors) I seem to be logged out (can't answer posts etc.), but when I click on "log-in" the tiki-wiki site tells me that I'm logged in already. I have to log out and log-in again, otherwise I can't use the forums. This happens everyday. Though once I do it (log-out, log-in) it works for the rest of the day.
Sounds like an acceptable workaround. It happens to me too sometimes, but I would rather not spend time on this when we have the KB to work on. Once we're off TikiWiki, this won't be a problem at all.

Comment 2

8 years ago
Do you use a nightly?  https://bugzilla.mozilla.org/show_bug.cgi?id=572223 says a patch recently landed causes random cookie loss.
(Reporter)

Comment 3

8 years ago
No, this happens with 3.6.8
Very likely due to rep lag in the sessions table. To fix, make tiki login set the DB pinning cookie like in multidb.middleware.PinningRouterMiddleware.
FYI, justdave mentioned yesterday that rep lag due to sessions table writes peaks around 4pm PDT - this bug would be most likely to happen then.
(In reply to comment #4)
> Very likely due to rep lag in the sessions table. To fix, make tiki login set
> the DB pinning cookie like in multidb.middleware.PinningRouterMiddleware.

This would imply that only the first n seconds of Kitsune page loads would appear unauthenticated. Yay! Something we can specifically test.

QA and/or Kadir: Can you check that you still appear logged out for a few seconds regardless of number of you refresh the page? This would only occur on prod.
Kadir, the next time this happens, is the page you appear not to be logged in at using http or https?
(Reporter)

Comment 8

8 years ago
James, not sure I understand what you mean. I have to click on "log-in", because I appear logged out, no matter how often I refresh the page or how long I wait, then on the log-in page I get the message that I am already logged in. Going back then I still can't post because I appear logged-out, again refreshing or waiting makes no difference. The only way around is to log out on the log-in page and log-in again. The strangest part: it only happens once a day, when I try to write my first post in the morning, then I can use it for the rest of the day.

Chris, this is regardless of http or https, I just tried both.

Comment 9

8 years ago
I've been hit by this two times the last few weeks. The solution seems to be to clear your support.mozilla.com cookies. Though it worries me that I got this a second time; would be good to find the cause of it.
At a high level, the issue is session cookies getting out of sync between Tiki and Django. Since we haven't found a reliable way to reproduce this it's been nearly impossible to diagnose or debug.

Kadir's comment implies that replication lag is at least not the whole story. (Though Erik's right that it's likely part of it.)

Kadir (or David) next time this happens, can you stop on whatever page you first notice it and check for a "sessionid" cookie?
(Reporter)

Comment 11

8 years ago
Okay, happened again today, here are the cookies I have from support.mozilla.org. I have not changed the standard Firefox rules for cookies. My local time is August 26th, 2010, 11:12:00

csrftoken
content: 2714a51b375bfdf32bb38ca6a04335b0
valid till: 24. August 2011 12:25:59

SUMOv1
content: fuuq6qn3sb2c9cgc04hv7u48p2
valid till: End of session

SUMOloggedin
content: true
valid till: End of session

tiki-user-smcremember
content: d3a7a726ae12c7192c5adf77259d5f85.1283374922.KadirTopal
valid till: 1. September 2010 23:02:13

SSLB_SUMO
content: 1
valid till: End of session

SSID_SUMO
content: AwCLjSkAAAAAI-p0TKRhDwIj6nRMAwD0LHZMAAAAAAAAAAD0LHZMAQAxAAAAvwAAAAI
valid till: 26. August 2011 10:59:32


SSSC_SUMO
content: 3.G5509285680260276644.3.49.191
valid till: End of session

SSRT
content: 9Cx2TAA
valid till: 26. August 2011 10:59:32


Looks like there is no cookie that lasts longer than 5 days.

Comment 12

8 years ago
My experience over the last week or two is that you don't have to log out and in again.

If I start with this URL from a bookmark
https://support.mozilla.com/en-US/questions?filter=my-contributions
then I sometimes get 'my contributions', sometimes it says I need to sign in.  Usually I hit the problem only once a day, but occasionally several times. 

If I click 'Sign In' it says I'm already logged in (different terminology BTW -
signed in/logged in). BUT if I then use the bookmark again it works.

This behaviour is different to when I first encountered this problem:
https://support.mozilla.com/en-US/forums/contributors/704588
I believe this has been fixed by not splitting sessions between Tiki and Django. Please reopen if anyone sees this again.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.