Multitouch: black boxes when zooming and a user can now pan

VERIFIED FIXED

Status

defect
--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: aakashd, Assigned: mbrubeck)

Tracking

Firefox Tracking Flags

(fennec2.0a1+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

9 years ago
Build id:
Mozilla/5.0 (Android; U; Linux armv71; en-US; rv:2.0b4pre) Gecko/20100818 Namoroka/4.0b4pre Fennec/2.0a1pre


Note: this is different from bug 584865. blassey mentions that bug was due to artifacts. This one seems to be some strange factoring 

Steps to Reproduce:
1. Go to addons.mozilla.org
2. Start a multitouch zoom
3. Move the bottom left finger up and down.

Actual Results:
Black boxes pop up in step 2 and the page starts panning in step 3

Expected Results:
Black boxes should not pop up in step 2 and the page should not pan in step 3.
Reporter

Updated

9 years ago
Summary: black boxes on zoom when zooming → Multitouch: black boxes when zooming and a user can now pan
Reporter

Updated

9 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b1+
tracking-fennec: 2.0b1+ → 2.0a1+
Assignee

Updated

9 years ago
Assignee: nobody → mbrubeck
Assignee

Comment 1

9 years ago
Posted patch patch (obsolete) — Splinter Review
If AnimatedZoom.finish() was called before the MozAsyncCanvasRender event was received, then (a) the event handler would fail because this.snapshot would be set to null, and (b) if a new AnimatedZoom object was created in the meantime, then it could render to the canvas while the previous render was still pending.

This patch prevents any use of the snapshot canvas while the MozAsyncCanvasRender event is still pending, and correctly handles the case where finish() is called before handleEvent().
Attachment #467279 - Flags: review?(webapps)
Assignee

Comment 2

9 years ago
Posted patch patch v2Splinter Review
Fix an exception when this.bv is undefined when finish() is called.
Attachment #467279 - Attachment is obsolete: true
Attachment #467287 - Flags: review?(webapps)
Attachment #467279 - Flags: review?(webapps)
Attachment #467287 - Flags: review?(webapps) → review+
Assignee

Comment 3

9 years ago
http://hg.mozilla.org/mobile-browser/rev/fa32126e5d30
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Reporter

Comment 4

9 years ago
verified FIXED on build:

Mozilla/5.0 (Android; U; Linux armv71; en-US; rv:2.0b4pre) Gecko/20100819 Namoroka/4.0b4pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.