Get Foundation Staff on the PTO App

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
4 years ago

People

(Reporter: katie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Hi there,

Your wonderful staff elaborated the PTO App to include location. Now the Foundation Staff can use it!!!  Only they can't... because our LDAP's don't give us access to the app.

Can you please give us permissions?

Thanks,
Katie

Updated

8 years ago
Assignee: server-ops → nobody
Group: infra
Component: Server Operations: Account Requests → PTO
Product: mozilla.org → Webtools
QA Contact: mrz → pto

Updated

8 years ago
Assignee: nobody → kourge

Comment 1

8 years ago
It's diagnosing time! When you try to log in to the PTO app, do you immediately get prompted for your username and password again?

Comment 2

8 years ago
Does this make any sense?  The PTO app is used by Mozilla HR, not Foundation HR.
(Reporter)

Comment 3

8 years ago
Jim Cook, the Foundation and Karen all want us on this thing.  Jim wants Messaging too... but that's their deal.  

There is no Foundation HR.  We use Karen, just as you do.

@kourge= yes, I immediately get prompted or my creds again.

Comment 4

8 years ago
Katie: do you have VPN access? Specifically, MPT VPN? I'm asking this because at this point I cannot determine the cause of this issue unless I have control of the server you're connecting to. The development server that I can access would make solving this a lot easier, but only if you can access it too, since it's only accessible through MPT VPN.
(Reporter)

Comment 5

8 years ago
Hi Wilson.

Hee hee. No, I don't have VPN access.  (That is another bug.)  HOWEVER, I do work at the Mtn View office 3x a week... and I'm currently on the Mozilla network when trying the link.  I'm upstairs next to 10 Forward if you want to check in... but I'll be WFH tomorrow and Friday.

Katie

Comment 6

8 years ago
So I talked to fox2mike and it seems like IT does maintain control over who has access to apps on intranet.mozilla.org, regardless of how the app is written.

Comment 7

8 years ago
mrz: As Katie said, HR, Finance, (e.g. Karen, Jim Cook) have all agreed upon this beforehand.
(Reporter)

Comment 8

8 years ago
Hey Wilson,

You stopped by my desk a few weeks ago and determined that the application version worked on your local machine, but the fix wasn't pushed to live.

Can you please update me on the status of this?

Thanks,
Katie

Comment 9

8 years ago
Katie:
Per comment 6, my fix is only partial, because IT will also have to enable access for Foundation folks on their side for this to work.
(Reporter)

Comment 10

8 years ago
Oh, so should the bug be assigned to someone else?

Updated

8 years ago
Assignee: kourge → server-ops

Updated

8 years ago
Assignee: server-ops → jlazaro
(Reporter)

Comment 11

8 years ago
Hi there,

Can I get an update on this bug please?

Katie

Updated

8 years ago
Assignee: jlazaro → nobody

Comment 12

7 years ago
Is this bug still valid? I see that the apache configuration is limiting access to o=com,dc=mozilla and no filters. To enable Foundation staff to log in, I could change it to just dc=mozilla with (objectClass=mozComPerson) as a filter.
That depends on the Foundation changing their process to use this app.

Please reopen if MoFo still wants this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.