profile-after-startup isn't working for Venkman on 3.6.8

RESOLVED FIXED

Status

Other Applications
Venkman JS Debugger
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Susan Crayne, Assigned: Gijs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

1.12 KB, patch
Karsten Düsterloh
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: 0.9.88

When I open Venkman in FF 4.0b3, I see a blank window, nothing else.  When I open Venkman in FF 3.6.8, I see only some of the functions of the addon that I am developing. I have installed a previous version of my addon and still don't see all the functions in the local scripts window.

Reproducible: Always

Steps to Reproduce:
1. Install Venkman 09.88
2. Open Firefox 4.0b3
3. Open Venkman
4. See blank window

Other problem, with FF 3.8.6 -- When I run Venkman, I see some of the .js files in my extension in the Local Scripts window -- not others.



I tried to install an earlier version of Venkman (0.9.87.4) into FF 3.8.6, and got a compatibility message, even though this version is advertised to work up to 4.0b4pre.

I am extremely dependent on Venkman in my work.  I have used it for many years and it has worked very well. Please help me to put together a version of Firefox and a version of Venkman that will work together.  Thank you.
(Assignee)

Comment 1

8 years ago
This issue was fixed by the last patch on bug 356267.

As for the scripts not appearing, this is because of a change in how Venkman works with the debugger service. I wrote about why you're seeing this, and how to deal with it, in a blog post here: http://www.gijsk.com/blog/2010/08/venkman-0-9-88-1/ . I hope that helps!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

8 years ago
Yes, no more blank screen with Firefox 4.  Thanks! Venkman is an essential tool for me.

As for the second issue, here is what I found (I posted these comments on your blog as well):


I installed venkman 9.88.1 in Firefox 3.8.6 on my Mac. I tried the “/startup-init true” command, but it did not do anything.

I installed Firefox 4.0b3 with venkman 9.88.1, and the “/startup-init true” works
(Reporter)

Comment 3

8 years ago
Sorry, 3.6.8
(Assignee)

Comment 4

8 years ago
So basically, the profile-after-change event fails to fire on 3.6.8, for whatever reason. MDC says it's supposed to work, so we're probably doing something wrong, but I haven't figured out what. Reopening so we can track this issue.

Susan: to workaround, I *think* you should be able to launch Venkman with the -venkman commandline switch, although I'm not entirely sure how one would do that on Mac (which I use myself - I've just always had issues with running Fx from the Terminal, YMMV)...
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: helpwanted
Resolution: FIXED → ---
Summary: Venkman shows blank screen in FF 4.0b3, in FF 3.6.8, can't see all of the functions in my extension → profile-after-startup isn't working for Venkman on 3.6.8
(Assignee)

Comment 5

8 years ago
Created attachment 470303 [details] [diff] [review]
Patch

This fix suggested by Neil seems to work. Doing the same for the commandline handler, as it had the same problem.
Assignee: nobody → gijskruitbosch+bugs
Status: REOPENED → ASSIGNED
Attachment #470303 - Flags: review?(mnyromyr)
(Assignee)

Updated

8 years ago
Keywords: helpwanted

Comment 6

8 years ago
Sorry, but I have no idea what this patch is meant to fix?!
And the commandline option -venkman didn't work with Firefox 3.6.9 at all...

(BTW: On Mac, if you installed Firefox.app under Applications, open Terminal, go to /Applications/Firefox.app/Contents/MacOS/ and run ./firefox-bin there.)
(Assignee)

Comment 7

8 years ago
(In reply to comment #6)
> Sorry, but I have no idea what this patch is meant to fix?!
> And the commandline option -venkman didn't work with Firefox 3.6.9 at all...
> 
> (BTW: On Mac, if you installed Firefox.app under Applications, open Terminal,
> go to /Applications/Firefox.app/Contents/MacOS/ and run ./firefox-bin there.)

If you use Venkman on 3.6.9, toggle /startup-init, JSD will not *actually* run on startup. The profile-after-change handler doesn't get called because of the 'service' setting. I just saw that the patch is somehow not correct (I have no idea why) - I tested the commandline handler, AFAICT it also won't work unless we take out the service flag.

Does that help?
(Assignee)

Comment 8

8 years ago
Created attachment 473726 [details] [diff] [review]
Patch I meant to attach
Attachment #470303 - Attachment is obsolete: true
Attachment #473726 - Flags: review?(mnyromyr)
Attachment #470303 - Flags: review?(mnyromyr)

Comment 10

8 years ago
Comment on attachment 473726 [details] [diff] [review]
Patch I meant to attach

Yeah, this patch makes more sense (and I can even test it against Mnenhy).
Also, you should add newlines to the dumps in lines 242 and 250...
Attachment #473726 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 11

8 years ago
(In reply to comment #10)
> Comment on attachment 473726 [details] [diff] [review]
> Patch I meant to attach
> 
> Yeah, this patch makes more sense (and I can even test it against Mnenhy).
> Also, you should add newlines to the dumps in lines 242 and 250...

Done, http://hg.mozilla.org/venkman/rev/662801d486aa .
(Assignee)

Comment 12

8 years ago
Gah, I've been away from bugzilla for too long. Sorry for spam, everyone.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.