Last Comment Bug 588724 - Browser daemon does not shut down properly when no connection and browser closed when Maemo connection dialog opens
: Browser daemon does not shut down properly when no connection and browser clo...
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: unspecified
: Other Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 02:51 PDT by Tero Turtiainen
Modified: 2016-02-05 09:05 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.34 KB, patch)
2010-08-19 02:55 PDT, Tero Turtiainen
cbiesinger: review+
Details | Diff | Splinter Review

Description Tero Turtiainen 2010-08-19 02:51:53 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: N900 maemo browser

When there is no active network connection and the Maemo browser is started and then closed with excatcly right timing, the "Select connection" dialog may appear. If you get the timing right, the browser attempts to close, but it is not properly shut down as nsMaemoNetworkManager is Waiting on a monitor that will no longer be Notified.

Reproducible: Always

Steps to Reproduce:
PRECONDITIONS: 
- No internet connnection, WLAN as automatic selection mode 
- no any paired WLANs awailable 

STEPS LEADING TO PROBLEM: 
1. Pick up N900. Tap some browser shortcut on desktop 
2. Wait for a moment when browser opens and starts to load page 
3. Tap browser to desktop mode (right down corner) (or set it up to open in
non-full screen mode)
4. Close browser (upper right corner) 
Do this before connection selection dialog pops up (step 6)! (Timing this is
quite tricky, repeat until you get it right)
5. Browser closes down 
6. Connection selection dialog opens
7. Do not select a connection just tap outside dialog to cancel it
Actual Results:  
Browserd is not closed cleanly.

Expected Results:  
Browserd is closed cleanly.

Also on current Maemo builds the browser UI process takes all the CPU it can get. But that is not Mozilla issue.
Comment 1 Tero Turtiainen 2010-08-19 02:55:09 PDT
Created attachment 467364 [details] [diff] [review]
Patch

With this patch we listen to quit-application instead of xpcom-shutdown and
when shutdown is detected, change the gInternalState on indicate that. And then
we can break out of the while-loop and not wait for something that will never
again be notified.

The reason for the bug is basically that in the test sequence, xpcon-shutdown is never sent so the nsMaemoNetworkManager::Shutdown is never called and the Monitor never notified.
Comment 2 Christian :Biesinger (don't email me, ping me on IRC) 2011-11-11 23:04:03 PST
Comment on attachment 467364 [details] [diff] [review]
Patch

Not sure if this is still relevant but r=biesi

Note You need to log in before you can comment on or make changes to this bug.