Export collected HTTP network data from Web Console

RESOLVED DUPLICATE of bug 859058

Status

()

Firefox
Developer Tools: Console
P3
normal
RESOLVED DUPLICATE of bug 859058
8 years ago
2 years ago

People

(Reporter: Honza, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [console-2])

(Reporter)

Description

8 years ago
One of the often required features for HTTP monitoring tools is export of all collected data (HTTP related) to a file for further/later processing.

Such feature allows to persist entire page loading process and:
1) replay it later
2) analyze load performance later

As part of Firebug development I have designed a HAR (HTTP Archive) format that is used for data exported from Firebug's Net panel. See more about Net export here: http://www.softwareishard.com/blog/netexport/

This format is based on JSON and described in detail here:
http://groups.google.com/group/http-archive-specification/web/har-1-2-spec

The format is already supported by many HTTP monitoring tools, the list is here: http://groups.google.com/group/http-archive-specification/web/har-adopters?hl=en

It would be very useful for developers if Web Console also supports exporting of collected HTTP data, especially using the same format that seems to slowly become an industry standard.

Honza

Updated

7 years ago
Whiteboard: [console-2]
Component: Developer Tools → Developer Tools: Console
OS: Windows Vista → All
Hardware: x86 → All
filter on TARDIS
Priority: -- → P3

Updated

5 years ago
Duplicate of this bug: 708717
Bug 859058 added HAR export.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859058
You need to log in before you can comment on or make changes to this bug.