When access this web, only can see a XML file and is an aircompany home

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Spanish
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Rafael, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre ( .NET CLR 3.5.30729)

Not do the redirection

Reproducible: Always
I can confirm this with SM trunk Gecko/20100819 and a new profile (no, it's not the adblock issue).

They are using a relative URL in their location field for the 302 but that works with ff4.0b3

Status: HTTP/1.1 302 Object moved
Set-Cookie:	AlteonP=affed149feedbababaee; path=/	
Connection:	close	
Date:	Thu, 19 Aug 2010 16:53:06 GMT	
Server:	Microsoft-IIS/6.0	
P3P:	CP="CAO PSA OUR"	
X-Powered-By:	ASP.NET	
Location:	index.aspx	
Content-Length:	131	
Content-Type:	text/html	
Set-Cookie:	ASPSESSIONIDAQBDQRTQ=CIFOIFJCCMMCAMLECJMIPAPP; path=/	
Cache-control:	private

Reporter: Do you know if this is a regression in todays build ?
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Alice0775 White: Could you help with a regression range ?

Comment 4

8 years ago
(In reply to comment #3)
> Alice0775 White: Could you help with a regression range ?

Detailed STR ?

Comment 5

8 years ago
Maybe it is site issue.
Because, UA spoof is effective.
(Reporter)

Comment 6

8 years ago
I discover the problem three days ago, on Tuesday.
STR:, 
load the given URL in the URL field with the latest trunk build.
I get a XML error page :

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<html><head><title>Object moved</title></head><body><h2>Object moved to <a href="">here</a>.</h2></body></html>

The redirect is followed with FF4.0b3
what do you mean with "UA spoof is effective." ?

Comment 8

8 years ago
> The redirect is followed with FF4.0b3
> what do you mean with "UA spoof is effective." ?

set general.useragent.extra.firefox to Firefox/3.6.8 instead of Minfiled/2.0b5pre
then the page load properly.
You are right, thanks for the hint !
I had to use a packet sniffer and the error message makes now sense.

HTTP/1.1 302 Found
Date: Fri, 20 Aug 2010 17:02:56 GMT
Server: Microsoft-IIS/6.0
P3P: CP="CAO PSA OUR"
X-Powered-By: ASP.NET
X-AspNet-Version: 2.0.50727
Location: 
Cache-Control: no-cache
Pragma: no-cache
Expires: -1
Content-Type: application/xhtml+xml; charset=utf-8
Content-Length: 117

<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="">here</a>.</h2>
</body></html>


moving to Tech Evangelism.
I will write a mail to spanair that their server is broken.
Assignee: nobody → spanish
Component: Networking: HTTP → Spanish
Product: Core → Tech Evangelism
QA Contact: networking.http → spanish
Version: Trunk → unspecified

Updated

8 years ago
Assignee: spanish → nobody
Component: Spanish → General
Product: Tech Evangelism → Firefox
QA Contact: spanish → general

Updated

8 years ago
Assignee: nobody → spanish
blocking2.0: ? → ---
Component: General → Spanish
Product: Firefox → Tech Evangelism
QA Contact: general → spanish
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.