[ga-IE] Localize Firefox 4 beta 4 whatsnew page and its associated videos

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
You have now a /4beta/whatsnew/ folder in your SVN repository (svn update).

Reminder, mozilla.com repo for your locale is:

https://svn.mozilla.org/projects/mozilla.com/trunk/YOURLOCALECODE/

The whatsnew beta 4 page is split in 2 tasks:
- translation of the page itself : 
 /firefox/4beta/whatsnew/content-beta4.html

- translation of the subtitles for two videos:
 /includes/l10n/videos/sub-fx4-sync.html
 /includes/l10n/videos/sub-fx4-grouptabs.html


The subtitles are a simple html file, each subtitle is enclosed in a <div>.

Please commit directly to SVN and indicate your revision numbers here or
alternatively, attach your files to this bug (upload them with the text/plain
MIME type in UTF8).

The staging site for the page is:
https://www-trunk.stage.mozilla.com/uk/firefox/4.0b3/whatsnew/

The sync video subtitles are the ones we had for beta 3 but were not used
because Sync was not shipped for that release, if you had translated it for
beta 3, no need to do anything on this one, it is the same file renamed. Same
with the Sync description which is already integrated in your beta4 html file
if you had translated it for beta3.



If you have any question, don't hesitate to ping me on irc (pascalc) or to put
a message in your bug.

Thanks

Comment 1

8 years ago
Lines 15 and 16 are near duplicates - I assume I should remove one?

Comment 2

8 years ago
Committed as r72570.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

8 years ago
Kevin, it was an error on my part, I meant to split the string in two to be less visually verbose on the screen and slightly update the timings but forgot to update the server, here is the diff if you feel it should be applied to your locale:
http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/pt-BR/includes/l10n/videos/sub-fx4-grouptabs.html?r1=72578&r2=72577&pathrev=72578

Comment 4

8 years ago
Thanks Pascal.  Timing tweaked slightly and committed as r72594.
(Reporter)

Comment 5

8 years ago
The grouptabs video was renamed panorama and is now located at:

/includes/l10n/videos/sub-fx4-panorama.php

The video script changed but I migrated your older strings to the new file, it will need adaptations though.

If you want to compare your translation with the original subtitles in English directly on the video for proof checking, you can add the ?comparesubs variable to your url on trunk:

http://www-trunk.stage.mozilla.com/fr/firefox/4.0b4/whatsnew/?comparesubs

(this new feature only works for the panorama video for now, it will also be used for the videos to come in next beta releases on whatsnew pages)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 6

8 years ago
The translation has been updated.   But most of the timings are pretty bad (my connections is a bit slow, I assume that's not the problem).  Is this something you can fix across all languages?
(Reporter)

Comment 7

8 years ago
yes I can fix that across all languages but I haven't seen any timings problems myself (and other localizers either), I'll check ga-IE closely to see if there is a specific problem with your version. Did you check that in Firefox beta/trunk or in 3.6?

Comment 8

8 years ago
Home now, and testing again with a fast connection, Mac OS X, FF 3.6.8, and the timing is perfect.    

The problem was on Linux, also FF 3.6.   The video kept buffering which may have been the root cause of the timing issues - I don't really know how the subtitling works so I'm not sure.
(Reporter)

Comment 9

8 years ago
I think you hit a specific Linux 3.6 bug with video but since this page is for 4.0beta and there is no bug anymore in this version, we are fine :)
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.