Closed Bug 588846 Opened 9 years ago Closed 9 years ago

Tabs disappear as TabCandy steals them

Categories

(Firefox Graveyard :: Panorama, defect)

x86
Windows 7
defect
Not set

Tracking

(blocking2.0 -)

RESOLVED DUPLICATE of bug 588712
Tracking Status
blocking2.0 --- -

People

(Reporter: pwd.mozilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre

TabCandy seems to be taking it upon itself to group, ungroup tabs and thus leaves users wondering where is the rest of their session.

Reproducible: Always
To add more information. I'll be happily surfing along with multiple tabs open and then for whatever reason, I'll notice that I'm down to far fewer tabs than I had open. I'll check TabCandy as that can be the only cause of the problem and there are the tabs. Some tiled out and some that only appear once you move another tab into a group.
Component: Tabbed Browser → TabCandy
QA Contact: tabbed.browser → tabcandy
blocking2.0: --- → ?
Version: unspecified → Trunk
Can't hold the release for this without more information. Can you please list the steps you take to make this happen?
blocking2.0: ? → -
I wish I knew Dietrich. Sometimes I'll be happily surfing along and then all of a sudden I've gone from 20 tabs to two. I decide that it's got to be down to TabCandy (which I never use) and so open TabCandy to find all the missing tabs there. I'm not sure what the problem is exactly, and the frequency in which it happens it becoming increasingly rarer, after all, it's only happened once in the past ten days. But I definitely wouldn't recommend release with such a bug. That said, if no one else has experienced such a problem or reported such a bug, I guess you're left with no choice.
Paul, can you tell us where you find those stolen tabs? Are they in some other group? Are they orphans (not in any group) scattered on the panorama screen, or at the bottom clumped together? What does it look like? What were you doing which may have triggered this?

All these hints would help us diagnose the problem.
Orphans in the bottom right of the screen in a pile. Though some don't appear until I move whatever was in the pile/stack in to a group.
I've definitely seen this, but I haven't been able to find reduced steps to reproduce. Starting with a fresh profile, I create a few app tabs, open a few more tabs, go into/out of private browsing mode, click on Panorama, and I'll find a group with my app tabs and what appears to be one thumbnail at the bottom right. It is in fact a stack of them corresponding to the other tabs.

It's not a sure way to reproduce the bug, but it also not difficult to get into this situation, on Win 7 or Mac (that I've tried). I'll work on steps to reproduce before confirming it.
I don't know what I'm doing to trigger it, but so far I can reproduce with the vague steps of: start out with a new profile in the morning, use it as your working browser, go in and out of panorama, try private browsing mode, and at some point you'll end up in a state where you'll have some missing thumbnails in your main group, only to find them stacked in the bottom right.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I have seen this without all of the above, just normal multi-tab browsing, no panorama, no private mode. At some time upon closing one single tab of maybe 20, all but the first one are gone and are found in TabView at the bottom right, one tab per group and all groups stacked exactly over each other.
(In reply to comment #8)
> I have seen this without all of the above, just normal multi-tab browsing, no
> panorama, no private mode. At some time upon closing one single tab of maybe
> 20, all but the first one are gone and are found in TabView at the bottom
> right, one tab per group and all groups stacked exactly over each other.

As above for me too. I've not gone in or out of panorama at all, mainly due to the fact I find the way it works alien to the windows experience, so I tend to try and stay away from it. I also don't use privacy browsing much. I know I'm really not helping the case here, but felt it better to offer up some information.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588712
Edward are we sure these are the same issue? I don't use TabCandy at all and yet have had it occasionally 'kidnap' tabs. Being that I'm using the nightlies I can't discount that this is something triggered by restarting as I restart daily. But I am not at all opening TabCandy except for to check if my missing tabs are there.
Sounds like bug 587990 is very similar to bug 588712.
Depends on: 587990
I have to agree with Paul - Bug 588712 is about problems with orphans that do not correctly get attached to a tab group. I experience the bug as described here, and I never used Panorama, just like Paul, I only checked it to see if my missing tabs have somehow gotten lost there, and voila, there they were. Happened after re-opening a closed tab.
I am on Win7, beta 9.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.