We are moving all storage over to the ConsoleStorageService now, so we can use the ConsoleStorage object for config/filtering prefs only now - as well as other things that might come up in the future. We should also rename this object. Let the bikeshedding begin!
ConsoleConfig? Whatever, we need not spend much time on the naming given that it's just an internal component for the Web Console.
Created attachment 499160 [details] [diff] [review] v 0.1 Code removal Patch This is a followup to all of the ConsoleStorageService bugs. This is purely code removal and will affect perf and memory use in a GOOD way:)
Comment on attachment 499160 [details] [diff] [review] v 0.1 Code removal Patch Can't approve without review.
Is this rotted or still needing review?
Comment on attachment 499160 [details] [diff] [review] v 0.1 Code removal Patch I will need to unbitrot this and remove some clutter
This is a console cleanup bug. Some day we should complete this patch. The ConsoleStorage object in HUDService is not very much needed, actually. We can handle prefs in a better way.
This will be fixed by my patch on bug 703235 .