If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove ConsoleStorage methods used for log message storage

RESOLVED DUPLICATE of bug 703235

Status

()

Firefox
Developer Tools
P2
normal
RESOLVED DUPLICATE of bug 703235
7 years ago
6 years ago

People

(Reporter: ddahl, Assigned: ddahl)

Tracking

(Blocks: 1 bug)

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [console-1])

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
We are moving all storage over to the ConsoleStorageService now, so we can use the ConsoleStorage object for config/filtering prefs only now - as well as other things that might come up in the future.

We should also rename this object. Let the bikeshedding begin!
(Assignee)

Updated

7 years ago
Blocks: 529086
(Assignee)

Updated

7 years ago
Assignee: nobody → ddahl

Comment 1

7 years ago
ConsoleConfig?

Whatever, we need not spend much time on the naming given that it's just an internal component for the Web Console.
Whiteboard: [kd4b5]

Updated

7 years ago
Whiteboard: [kd4b5] → [kd4b7]

Updated

7 years ago
Whiteboard: [kd4b7]
(Assignee)

Comment 2

7 years ago
Created attachment 499160 [details] [diff] [review]
v 0.1 Code removal Patch

This is a followup to all of the ConsoleStorageService bugs. This is purely code removal and will affect perf and memory use in a GOOD way:)
Attachment #499160 - Flags: review?(dietrich)
Attachment #499160 - Flags: approval2.0?

Updated

7 years ago
Blocks: 593956
Priority: -- → P2
Comment on attachment 499160 [details] [diff] [review]
v 0.1 Code removal Patch

Can't approve without review.
Attachment #499160 - Flags: approval2.0? → approval2.0-
(Assignee)

Updated

7 years ago
Whiteboard: [console-1]
Is this rotted or still needing review?
(Assignee)

Comment 5

7 years ago
Comment on attachment 499160 [details] [diff] [review]
v 0.1 Code removal Patch

I will need to unbitrot this and remove some clutter
Attachment #499160 - Flags: review?(dietrich)
This is a console cleanup bug. Some day we should complete this patch. The ConsoleStorage object in HUDService is not very much needed, actually. We can handle prefs in a better way.
Blocks: 592463

Updated

6 years ago
Blocks: 703235

Comment 7

6 years ago
This will be fixed by my patch on bug 703235 .

Updated

6 years ago
No longer blocks: 703235

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703235
You need to log in before you can comment on or make changes to this bug.