If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Loading messages from previous betas does not default to "30D"

VERIFIED FIXED in 1.8

Status

Input
General
P2
normal
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: aakashd, Assigned: ryansnyder)

Tracking

Details

(Reporter)

Description

7 years ago
Steps to Reproduce:
1. Go to http://input.stage.mozilla.com/en-US/search/?product=firefox&version=4.0b2&date_start=2010-08-12
2. Open up the "version" combobox
3. Click on any past version of the Fx beta

Actual Results:
The resulting page does shows comments on that beta made over the past 7 days (i.e. none because we block submission).

Expected Results:
The resulting page should show all comments over that previous beta related to the search query.
I'd argue this is expected: The button on the front page defaults to 1d, and unless you change it, this is what remains checked when you switch other options, like the version.
(Reporter)

Comment 2

7 years ago
It's odd user experience because we're blocking submission on past releases of Firefox betas. So, our dashboard should be smart enough to guide the user to the most optimal viewpoint for the feedback he/she is trying to read.
Target Milestone: 1.7 → 1.8
This actually wfm -- but Ryan might have fixed it in the mean time.

STR the fix:
- Go to the input.stage front page
- change the version in the combobox

A search over the span of 30 days is executed.

Doing the same things on the URL in comment 0 keeps the start date (August 12) as specified in the URL, which is expected.
Assignee: nobody → ryan
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified FIXED, as Fred said; I get a URL like http://input.stage.mozilla.com/en-US/search/?product=firefox&date_start=2010-08-04&date_end=&version=4.0b1, which preserves the params just fine.
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.