TBPL is not working for Tracemonkey/JaegerMonkey

VERIFIED FIXED

Status

VERIFIED FIXED
8 years ago
4 years ago

People

(Reporter: dmandelin, Assigned: rhelmer)

Tracking

Trunk
x86
Windows 7

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
It never gets past "Loading pushlog..." on the top. It was like this since this morning.
(Assignee)

Comment 1

8 years ago
Getting this in the error console for Tracemonkey:

Error: /([^<]+) /.exec(patch.author) is null
Source File: http://tests.themasta.com/tinderboxpushlog/js/PushlogJSONParser.js
Line: 20
Try TM after 8:30 tonight, and JM after 11:13 tonight - those thousand-changeset merges are hard on pushlog, and it tends not to manage to finish before tbpl times it out.

Comment 3

8 years ago
The same problem is happening on TryServer's TBPL now.
(Assignee)

Comment 4

8 years ago
I think this is happening because author names don't always have in brackets (most but not all are "User Name <email>", some are just "email"):

$ curl -s 'http://hg.mozilla.org/try/json-pushes?full=1&startdate=12+hours+ago&enddate=now' | grep author | grep -v '<'
    "author": "curtisb@curtis-bartleys-macbook-pro.local",

Regression caused by bug 584836?
(Assignee)

Comment 5

8 years ago
Created attachment 467606 [details] [diff] [review]
check for < in author name before using regex
Attachment #467606 - Flags: review?(arpad.borsos)
(Assignee)

Updated

8 years ago
Attachment #467606 - Flags: review?(mstange)
Comment on attachment 467606 [details] [diff] [review]
check for < in author name before using regex

We can just tweak the regex to exclude the space. Pushed with that change (and a trim() around it to remove a possible trailing space):
http://hg.mozilla.org/users/mstange_themasta.com/tinderboxpushlog/rev/1fd4bd863cc7
Attachment #467606 - Flags: review?(mstange)
Attachment #467606 - Flags: review?(arpad.borsos)
Attachment #467606 - Flags: review+
Assignee: nobody → robert
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

8 years ago
WFM locally using a pushlog JSON feed with missing "<".
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

8 years ago
Thanks very much! This is a key time for the JS team, and I've been really relying on TBPL, so it was great to have a prompt fix.
Product: Webtools → Tree Management
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.