Crash printing directions

VERIFIED FIXED in mozilla0.9

Status

()

Core
Printing: Output
P3
critical
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: shrirang khanzode, Assigned: Kevin McCluskey (gone))

Tracking

({crash})

Trunk
mozilla0.9
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
bug 55192 was reported for a similar problem.

Steps:

1. Go to the above url
2 enter FROM/TO addresses and get directions
3 Select 'File|Print'
4 Observe that the pages print but the browser crashes.



Stack Trace:


 Call Stack:    (Signature = 0x006f006e e35a64aa) 
     
   0x006f006e 
                                    
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 95]
     
   nsBoxFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1003]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsBoxFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1003]
     
   nsGfxScrollFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 
452]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsBoxFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1003]
     
   nsGfxTextControlFrame2::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame2.cpp, 
line 1166]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsLineBox::DeleteLineList 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 252]
     
   nsBlockFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1232]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsTableFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 269]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsTableOuterFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
64]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsBlockFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1230]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsTableFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 269]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsTableOuterFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
64]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsBlockFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1230]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsTableFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 269]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsTableOuterFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
64]
     
   nsLineBox::DeleteLineList 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 252]
     
   nsBlockFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1232]
     
   nsLineBox::DeleteLineList 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 252]
     
   nsBlockFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1232]
     
   nsLineBox::DeleteLineList 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineBox.cpp, line 252]
     
   nsBlockFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1232]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]
     
   nsContainerFrame::Destroy 
                                   
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 98]
     
   nsFrameList::DestroyFrames 
                                   
[d:\builds\seamonkey\mozilla\layout\base\src\nsFrameList.cpp, line 36]

Comment 1

18 years ago
Adding rtm keyword
Keywords: rtm

Comment 2

18 years ago
Adding Lisa to cc list

Comment 3

18 years ago
Does this happen on all platforms?  

Comment 4

18 years ago
Is there a way to reduce this test case?
Status: NEW → ASSIGNED

Comment 5

18 years ago
Can you also find out if this is a regression.. if so.. what day it regressed.
Seems to work on the trunk.. but the branch is crashed..  after the printout 
came out.

Comment 6

18 years ago
This crashes on Windows, Mac, and Linux with the limbo 2 builds
(Reporter)

Comment 7

18 years ago
Does not seem to be a regression. I could track this problem to builds as late 
as sept 29. 
(Assignee)

Comment 8

18 years ago
Marking rtm need info.
Whiteboard: [rtm need info]
(Assignee)

Comment 9

18 years ago
Created attachment 18601 [details]
Somewhat reduced test case

Comment 10

18 years ago
What is it about the resulting pages that cause this crash?

Comment 11

18 years ago
Looking at this with the trunk build.. Chris can you look also.. could this be 
that incremental reflow.. null pointer type bug you fixed for some table things.  
This sounds awfuly familiar.

Comment 12

18 years ago
This is not the kind of bug I think you mean. A view is being accessed during 
frame destruction but the view has already been destroyed.

Comment 13

18 years ago
Does this sound like that one bug that Chris Waterson fixed a few weeks ago?
(Assignee)

Comment 14

18 years ago
Adding crash keyword.
The crash seems to be caused by having a table which is split across two pages
when printing. If you reduce the number of items in either table in the reduced
test case it stops crashing.
Keywords: crash
(Assignee)

Comment 15

18 years ago
I recall that don had a bug similar to this, that was fixed a month or so ago.
The problem was that the view was reparented incorrectly by
MoveOverflowToChildList. This page also causes a MoveOverflowToChildList call to
be generated:



stack trace which shows view being reparented while printing.


nsView::RemoveChild(nsView * const 0x03585630, nsIView * 0x0360e060) line 822
nsViewManager2::RemoveChild(nsViewManager2 * const 0x030ef610, nsIView *
0x03585630, nsIView * 0x0360e060) line 1629
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa1244,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line 188
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa11a0,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa1080,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa100c,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa0ec8,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa0e40,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa0de0,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa0ac4,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa06ec,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa0684,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa0630,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa0504,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00fa04a4,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
ReparentFrameViewTo(nsIPresContext * 0x03044ab0, nsIFrame * 0x00f9f9fc,
nsIViewManager * 0x030ef610, nsIView * 0x0364de40, nsIView * 0x03585630) line
196 + 25 bytes
nsHTMLContainerFrame::ReparentFrameView(nsIPresContext * 0x03044ab0, nsIFrame *
0x00f9f9fc, nsIFrame * 0x00ef1fb0, nsIFrame * 0x00f0450c) line 318 + 30 bytes
nsContainerFrame::MoveOverflowToChildList(nsIPresContext * 0x03044ab0) line 1018
+ 21 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x00f04370,
nsIPresContext * 0x03044ab0, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 1089
nsContainerFrame::ReflowChild(nsIFrame * 0x00f04370, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsTableFrame::ReflowMappedChildren(nsTableFrame * const 0x00f04408,
nsIPresContext * 0x03044ab0, nsHTMLReflowMetrics & {...}, InnerTableReflowState
& {...}, unsigned int & 0) line 3132 + 47 bytes
nsTableFrame::ResizeReflowPass2(nsTableFrame * const 0x00f04408, nsIPresContext
* 0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 2074 + 31 bytes
nsTableFrame::Reflow(nsTableFrame * const 0x00f04408, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1714 + 34 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x00f04408, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 3, unsigned int & 0) line 693 + 31 bytes
nsTableOuterFrame::OuterReflowChild(nsTableOuterFrame * const 0x00f043b4,
nsIPresContext * 0x03044ab0, nsIFrame * 0x00f04408, const nsHTMLReflowState &
{...}, nsHTMLReflowMetrics & {...}, int * 0x00000000, nsSize & {...}, nsMargin &
{...}, nsMargin & {...}, nsMargin & {...}, nsReflowReason eReflowReason_Initial,
unsigned int & 0) line 900 + 47 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x00f043b4, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1440 + 69 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason
eReflowReason_Initial, nsIFrame * 0x00f043b4, const nsRect & {...}, int 0, int
0, int 1, nsMargin & {...}, unsigned int & 0) line 561 + 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x00f043b4, const nsRect & {...},
int 0, int 0, int 1, nsMargin & {...}, unsigned int & 0) line 331 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x00f04470, int * 0x0012a790) line 3884 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x00f04470, int
* 0x0012a790, int 0) line 3149 + 23 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2956 + 27 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x00f04498, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1746 + 15 bytes
nsBlockReflowContext::DoReflowBlock(nsHTMLReflowState & {...}, nsReflowReason
eReflowReason_Initial, nsIFrame * 0x00f04498, const nsRect & {...}, int 0, int
0, int 1, nsMargin & {...}, unsigned int & 0) line 561 + 36 bytes
nsBlockReflowContext::ReflowBlock(nsIFrame * 0x00f04498, const nsRect & {...},
int 0, int 0, int 1, nsMargin & {...}, unsigned int & 0) line 331 + 50 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox *
0x00f044e4, int * 0x0012b2c8) line 3884 + 56 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x00f044e4, int
* 0x0012b2c8, int 0) line 3149 + 23 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2956 + 27 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x00f04544, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1746 + 15 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x00f04544, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsPageFrame::Reflow(nsPageFrame * const 0x00f0450c, nsIPresContext * 0x03044ab0,
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 129
nsContainerFrame::ReflowChild(nsIFrame * 0x00f0450c, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int
100, int 15378, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsSimplePageSequenceFrame::Reflow(nsSimplePageSequenceFrame * const 0x00ef1f74,
nsIPresContext * 0x03044ab0, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 248
nsContainerFrame::ReflowChild(nsIFrame * 0x00ef1f74, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x00ef1f38, nsIPresContext *
0x03044ab0, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 546
PresShell::InitialReflow(PresShell * const 0x030ee4b0, int 11520, int 15178)
line 2350
DocumentViewerImpl::Print(DocumentViewerImpl * const 0x034839a8, int 0, _iobuf *
0x00000000, nsIPrintListener * 0x00000000) line 1670
nsBrowserInstance::Print(nsBrowserInstance * const 0x03030c50) line 1496 + 29 bytes
XPTC_InvokeByIndex(nsISupports * 0x03030c50, unsigned int 33, unsigned int 0,
nsXPTCVariant * 0x0012c0c0) line 139
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x01621e70,
nsXPCWrappedNative * 0x03034500, const XPCNativeMemberDescriptor * 0x03034944,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 0, long *
0x00f8a0c0, long * 0x0012c274) line 913 + 43 bytes
WrappedNative_CallMethod(JSContext * 0x01621e70, JSObject * 0x00f22050, unsigned
int 0, long * 0x00f8a0c0, long * 0x0012c274) line 228 + 34 bytes
js_Invoke(JSContext * 0x01621e70, unsigned int 0, unsigned int 0) line 820 + 23
bytes
js_Interpret(JSContext * 0x01621e70, long * 0x0012cdd8) line 2622 + 15 bytes
js_Invoke(JSContext * 0x01621e70, unsigned int 1, unsigned int 2) line 837 + 13
bytes
js_InternalInvoke(JSContext * 0x01621e70, JSObject * 0x00f72cf0, long 16198912,
unsigned int 0, unsigned int 1, long * 0x0012cf70, long * 0x0012cf00) line 909 +
20 bytes
JS_CallFunctionValue(JSContext * 0x01621e70, JSObject * 0x00f72cf0, long
16198912, unsigned int 1, long * 0x0012cf70, long * 0x0012cf00) line 3193 + 31 bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x01620080, void * 0x00f72cf0,
void * 0x00f72d00, unsigned int 1, void * 0x0012cf70, int * 0x0012cf6c, int 0)
line 915 + 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x03573ca0) line 154 + 64 bytes
nsXBLPrototypeHandler::ExecuteHandler(nsXBLPrototypeHandler * const 0x02f420f0,
nsIDOMEventReceiver * 0x02cc1168, nsIDOMEvent * 0x03573ca0) line 314
nsXBLWindowKeyHandler::WalkHandlersInternal(nsXBLWindowKeyHandler * const
0x02c814a0, nsIDOMKeyEvent * 0x03573ca0, nsIAtom * 0x025a5970,
nsIXBLPrototypeHandler * 0x02f43bc0) line 255 + 48 bytes
nsXBLWindowKeyHandler::WalkHandlers(nsXBLWindowKeyHandler * const 0x02c814a0,
nsIDOMEvent * 0x03573ca4, nsIAtom * 0x025a5970) line 295
nsXBLWindowKeyHandler::KeyPress(nsIDOMEvent * 0x03573ca4) line 311
nsEventListenerManager::HandleEvent(nsIPresContext * 0x025f3400, nsEvent *
0x0012f8bc, nsIDOMEvent * * 0x0012f480, nsIDOMEventTarget * 0x025f1760, unsigned
int 2, nsEventStatus * 0x0012f828) line 1118 + 23 bytes
nsXULDocument::HandleDOMEvent(nsXULDocument * const 0x025f1740, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 2014
nsXULElement::HandleDOMEvent(nsXULElement * const 0x0261cbe0, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 3328 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x02c87490, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 3322 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x029815b0, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 3322 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x02c8ae80, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 3322 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x02c8adb0, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 3322 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x02c8ac50, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 3322 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x02c8a830, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 3322 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x0306bf30, nsIPresContext *
0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 2,
nsEventStatus * 0x0012f828) line 3322 + 39 bytes
nsGenericElement::HandleDOMEvent(nsIPresContext * 0x025f3400, nsEvent *
0x0012f8bc, nsIDOMEvent * * 0x0012f480, unsigned int 1, nsEventStatus *
0x0012f828) line 1424 + 45 bytes
nsHTMLInputElement::HandleDOMEvent(nsHTMLInputElement * const 0x0306bd3c,
nsIPresContext * 0x025f3400, nsEvent * 0x0012f8bc, nsIDOMEvent * * 0x00000000,
unsigned int 1, nsEventStatus * 0x0012f828) line 903 + 31 bytes
PresShell::HandleEventInternal(nsEvent * 0x0012f8bc, nsIView * 0x025f47e0,
unsigned int 1, nsEventStatus * 0x0012f828) line 4916 + 47 bytes
PresShell::HandleEvent(PresShell * const 0x025f7444, nsIView * 0x025f47e0,
nsGUIEvent * 0x0012f8bc, nsEventStatus * 0x0012f828, int 1, int & 1) line 4851 +
25 bytes
nsView::HandleEvent(nsView * const 0x025f47e0, nsGUIEvent * 0x0012f8bc, unsigned
int 28, nsEventStatus * 0x0012f828, int 1, int & 1) line 379
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x025f49c0, nsGUIEvent *
0x0012f8bc, nsEventStatus * 0x0012f828) line 1439
HandleEvent(nsGUIEvent * 0x0012f8bc) line 68
nsWindow::DispatchEvent(nsWindow * const 0x025f46a4, nsGUIEvent * 0x0012f8bc,
nsEventStatus & nsEventStatus_eIgnore) line 682 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f8bc) line 703
nsWindow::DispatchKeyEvent(unsigned int 131, unsigned short 112, unsigned int 0)
line 2293 + 15 bytes
nsWindow::OnChar(unsigned int 16, unsigned int 0, unsigned char 0) line 2417
nsWindow::ProcessMessage(unsigned int 258, unsigned int 16, long 1638401, long *
0x0012fc44) line 2850 + 33 bytes
nsWindow::WindowProc(HWND__ * 0x003c02de, unsigned int 258, unsigned int 16,
long 1638401) line 958 + 27 bytes
USER32! 77e7124c()


Don, any idea on what bug that was?
(Assignee)

Comment 16

18 years ago
Ok, bug 44718 was the bug I was talking about.
The fix for 44718 just stopped it from crashing, it did not fix the underlying
problem.

For bug 44718, Don added code to nsHTMLContainerFrame to "give up" if the view
hierarchy was messed up.

nsHTMLContainerFrame: Line 176

// you have to check all the time to see if this
// view has been reparented.. if you try to insert for
// a view that has been reparented.. bad things can happen.
// I took out the debug check and check all the time now..
// this case happens when you print.
view->GetParent(parentView);
if(parentView != aOldParentView)
return NS_OK;

//NS_ASSERTION(parentView == aOldParentView, "unexpected


The return is being hit on this page as well. So parentView != aOldParentView.

Comment 17

18 years ago
Would bug 53690 fall into place here?  This bug was fixed in the 11/3 branch
builds and has to do with printing long table failing.  I'm just wondering if
that is tied in in any way.

Comment 18

18 years ago
I think I already applied the patch for bug 53690, and it didn't fix the problem 
here.

Comment 19

18 years ago
Is there anything like a null pointer check that could prevent this crash?  If
so, please attach such a patch to the bug and get reviews.  If there's another
respin that type of patch might go along for the ride.

Comment 20

18 years ago
Sounds like release note material to me.  We're not going to be able to fix all
known crashers at this late date.  Recommend minus.

Comment 21

18 years ago
*** Bug 59656 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

18 years ago
The crash can not be prevented using a simple null-pointer check. The crash is
caused by layout incorrectly parenting a view while breaking a table across page
boundaries during printing.

Marking rtm-.
Will continue to investigate.
Whiteboard: [rtm need info] → [rtm-]

Comment 23

18 years ago
I see this on Mac too, setting to all platforms/OS
OS: Windows NT → All
Hardware: PC → All

Comment 24

18 years ago
*** Bug 59006 has been marked as a duplicate of this bug. ***

Comment 25

18 years ago
*** Bug 64385 has been marked as a duplicate of this bug. ***

Comment 26

18 years ago
*** Bug 67042 has been marked as a duplicate of this bug. ***
nominating for mozilla1.0 and nsbeta1.
Keywords: mozilla1.0, nsbeta1
(Reporter)

Comment 28

18 years ago
spam : changing qa to sujay (new qa contact for Printing)
QA Contact: shrir → sujay
(Assignee)

Comment 29

17 years ago
Setting milestone to mozila0.9.1
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 30

17 years ago
sujay: could you try to reproduce with a current build. I checked in a fix today
which should get rid of this crash? thanks

Comment 31

17 years ago
I'll verify this in today's 3/23 build.
(Assignee)

Comment 32

17 years ago
Taking this bug.
Assignee: dcone → kmcclusk
Status: ASSIGNED → NEW
(Assignee)

Comment 33

17 years ago
This is fixed in the current build.
To verify:
- goto www.netscape.com
- click on maps
- print the page

It crashes in earlier builds, but does not crash in the latest build.
I checked in a fix to code which reparents the views to include the frames
floater list and it must have fixed this printing crash as well.

Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Target Milestone: mozilla0.9.1 → mozilla0.9

Comment 34

17 years ago
This is still crashing in my build.  Build 2001031604, running on NT4.0, SP6a,
256MBRAM, AMD Duron 600.
Probably because you are running a build from the 16th... try with a nightly please.

Comment 36

17 years ago
Duh.  Nevermind - fetchbuild grabbed me an old build (not thinking - saw the
"0316" I typed _after_ I hit the commit button).  I'll retry on a real "today's"
build.  Sorry for the spam.

Comment 37

17 years ago
verified in 4/4 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.