If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Infinite "Looking up smtp.googlemail.com" after some minutes

VERIFIED WORKSFORME

Status

()

Core
Networking
VERIFIED WORKSFORME
7 years ago
6 years ago

People

(Reporter: dryannof@gmail.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has protocol logs])

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100802 Thunderbird/3.1.2

Since version 3 (first official release) after opening Thunderbird all
goes fine when I send mail. However, after some time (could be minutes)
Thunderbird gives me the SMTP sending poblem. 
I can ping by CMD Shell smtp.googlemail.com (also smtp.gmail.com) without any problems. Also firewall etc is ok. So the problem has nothing to do with
DNS or firewall NAT etc.
No extra add-ons etc installed.

I have about 22 gmail accounts at Thunderbird atm, with IMAP. All of them have less than 10 mails at inbox. (i delete them after reading)
Also i have some RSS Feeds, that i read through Thunderbird, and many times i forward those pages (links or text from feeds) to my friends and co-workers.
If i open Thunderbird and immediately type and send an email, everything goes fine. But if i wait a bit, to read my incoming, and read few rss feeds, and then i try to write a mail, or forward a mail/feed then i get the "Looking up smtp.googlemail.com" infinite loading. If i cancel, i get the SMTP sending poblem.
I have found a temporarily solution, almost for the past year, but now it is time to report this error, because it happened to my friends Thunderbird also. (default config, 5-10 gmails and some rss)
Read emails, feeds etc as normal. When i want to type an email or forward something, and then i select from Menu File->Send Later.
Then i close and reopen thunderbird, and it asks me if want to send unsent messages. Ofcourse i press yes, and voila, messages sent.

Reproducible: Sometimes

Steps to Reproduce:
1.Open Thunderbird
2.Read Some mail, rss feeds, let some time pass (3+minutes)
3.Try to write and send a mail / or forward a mail
4.Infinite "Looking up smtp.googlemail.com"


Expected Results:  
Mail Sent Successfully
Can you log nsHostResolver:5 as described at https://wiki.mozilla.org/MailNews:Logging and post the log here ?

Is ipv6 enabled on your machine ?
(Reporter)

Comment 2

7 years ago
Created attachment 467748 [details]
logfile nsHostResolver:5
(Reporter)

Comment 3

7 years ago
Created attachment 467749 [details]
LookingUpSMTP Loading
(Reporter)

Comment 4

7 years ago
Created attachment 467750 [details]
ResultAfter LookingUpSMTP Message
(Reporter)

Comment 5

7 years ago
ipv6 is enabled by default in windows vista and 7. in our case windows 7 ultimate x64
What's the value of network.dns.disableIPv6 on your machine ?
(Reporter)

Comment 7

7 years ago
I noticed that if i leave thunderbird for some time (for example now, i got out to eat) and come back, i am able to send mails. Maybe this is some kind of limited simultaneous connections, that after some time expire giving space for new connections? im just saying
Component: General → Networking: SMTP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.smtp
I'm not seeing anything in the logs. Wada any idea of what could be going wrong ?
Whiteboard: [has protocol logs]
(Reporter)

Comment 9

7 years ago
in about:config

Preference Name               Status      Type       Value
network.dns.disableIPv6       default     boolean    false
(Reporter)

Comment 10

7 years ago
I dont know either what is causing this.
Before the format i used vista, and it was happening everytime. 2-3 minutes after thunderbird start and i had to restart it to send mails.
Now with win7 this issue appears less frequently and not all the times. Thats why i have placed it as "Reproducible: Sometimes".
Anything i can do to help track this problem to its source... let me know.

i will perform the same test again tomorrow and submit the new log
(Reporter)

Comment 11

7 years ago
Created attachment 467759 [details]
message when i close the mail window
(Reporter)

Comment 12

7 years ago
also steps i used to create the log: (in cmd)

cd C:\
set NSPR_LOG_MODULES=nsHostResolver:5
set NSPR_LOG_FILE=%TEMP%\log.txt
cd "Program Files (x86)\Mozilla Thunderbird"
.\thunderbird.exe

Comment 13

7 years ago
I am experiencing the same issue on Mac OS X and Solaris.  Both x86 and Sparc.  I have been experiencing this issue since 2.x to current.  The problem is easily reproducible, as indicated above.

Initially, I suspected DNS.  It was not a server problem, and although I eliminated the DNS possibility via pings and telnet's to port 25, I even went as far as adding a host entry.

My next thought was I was running out of file descriptors.  I have 37 accounts I am connecting to, each with many folders.  In testing, I have file descriptors set to 65536, and I have never seen Thunderbird use over 200.  This was verified using the "pfiles" command on Solaris.

I do have a work around, that I hope will assist in troubleshooting this issue.  When I do run into the "Looking up <mail server>" error, I can click the "offline" button at the bottom left of the window to go offline, followed by clicking again to go back on line.  

This work around leaves firefox functional for a while, till the issue shows up again.
Component: Networking: SMTP → Networking
Product: MailNews Core → Core
QA Contact: networking.smtp → networking
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

6 years ago
After applying the latest Build 7.0.1, the above issue no longer exists.
I am able to leave Thunderbird Running, for as long as i want, and be able to receive/send emails without any SMTP problem.

By the way, no other software/hardware changes have been made to the computers.
Just saying that, to counter any possibility that other changes might have fixed the bug.
Specifically, one computer with the old 3.1.2 client has been in my warehouse. After a year of the pc being offline (and therefore no changes were made to software or hardware), i updated the client to 7.0.1. Works there too.

Thanks to everyone, especially the programmers, who found and resolved this issue, whatever it was.

And since this Bug Thread has been left as Unresolved for the past months, I now change its status to Resolved.

I recommend to anyone experiencing the same issue, to update to 7.0.1 and if possible leave a comment also.
You need to log in before you can comment on or make changes to this bug.