Closed Bug 589117 Opened 11 years ago Closed 9 years ago

Printing only selected text doesn't work

Categories

(MailNews Core :: Printing, defect)

x86_64
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 66806

People

(Reporter: will.pittenger1+mozbugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722 Ant.com Toolbar 2.0.1 Firefox/3.6.8 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.11) Gecko/20100711 Thunderbird/3.0.6

I selected text in the preview pane of the main window and then opened the Print dialog.  The radio button to cause it to print only selected text was disabled.  This was true no matter how I went in there.  This affects only TB.  Firefox is able to print selected text normally.

I get the impression this feature wasn't implemented.  It would really help though as I recently got a long e-mail I only needed part of.  Granted, the dialog needs to handle the case in which the user want to print multiple e-mails at once.  However, for that, I would suggest adding controls to the dialog like Firefox adds options for how to print frames.

Reproducible: Always

Steps to Reproduce:
1. Select some text in an e-mail
2. Open File/Print
3. The Selected only button will be disabled
Actual Results:  
TB insists on printing only entire e-mails.

Expected Results:  
Most users expect when something is text to be able to select some text and print just that.

While I marked x64 as the platform, that is only the version of Windows I run.  TB is 32-bit.
Component: Printing: Output → Printing
Product: Core → MailNews Core
QA Contact: printing → printing
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 66806
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.