Cannot change background color for single characters/words while composing new message

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: artee, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; pl; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100802 Lightning/1.0b2pre Thunderbird/3.1.2

Cannot change background color for selected characters/words while composing new message. 

Reproducible: Always

Steps to Reproduce:
1. Enter some text into composition windows.
2. Select single character/word
3. Change background color for such selection
4. New background color is applied on whole page instead of current selection.
5. Foreground color works as expected
Actual Results:  
4. New background color is applied on whole page instead of current selection.

Expected Results:  
Changed background color should be applied to current selection instead of whole mail.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1

Comment 1

8 years ago
artee,

The current state of the html editor does not provide a user interface to do what you want to do. Therefore marking this as invalid, but this does not invalidate your desire to accomplish what you want in thunderbird.
You can get several different types of text backgrounds, but you must edit the code directly and learn a little about CSS. There are compatibility issues with your recipient that you should consider however depending on what mail software he is using. (see the attachment EML for a sample of what can be done in TB)

You might be interested in this extension as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 2

8 years ago
Created attachment 467913 [details]
sample highlighting text

Comment 3

8 years ago
Forgot to include the extension link:
https://addons.mozilla.org/en-US/thunderbird/addon/4394/
(Reporter)

Comment 4

8 years ago
> You can get several different types of text backgrounds, 
Yes, I know, because I'm a programmer :D
This rather basic functionality is implemented in several other mail clients, even in Outlook Express.
My co-workers use this functionality to highlight some portion of text.
Foreground 'highlight' works fine, background 'highlight' doesn't (whole e-mail is affected).

> your recipient that you should consider however depending on what mail 
To be more consistent, this functionality is implemented in standard HTML since 90'. We are talking about background color only because this option is available from the TB UI.

> You might be interested in this extension as well.
This extension is addressed to HTML templates AFAIK :)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

8 years ago
You might be interested in this extension:
https://addons.mozilla.org/en-US/thunderbird/addon/222207/
It's still in the early stages of development, but works fine for me.
And..BTW, notice that it is an extension which adds functionality to the App
So this report NOT being a bug in the code, it should be considered INVALID or an enhancement request.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.