[Firefox Menu Button]Position of the bookmark is strange and does not correctly update.

RESOLVED FIXED in Firefox 4.0b7

Status

()

Firefox
Menus
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
Firefox 4.0b7
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [fixed in bug 592900])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre ID:20100820033948
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100819 Minefield/4.0b5pre ID:20100820033948

After drag and drop bookmarks, the position of the bookmark is strange.
You can confirm the correct position in Library.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Create Bookmarks/folders and placed within "Bookmarks Menu"
3. Open Bookmarks popup ( "Firefox Menu" > "Bookmarks >" )
4. Drag & drop bookmark/folder

Actual Results:
 Position of the bookmark which I dragged & dropped is strange.
 You can confirm the correct position in Library.

Expected Results:
 The bookmark should be at the position of the indicator
(Reporter)

Updated

8 years ago
Summary: [Firefox Menu Button]Position of the bookmark is strange. → [Firefox Menu Button]Position of the bookmark is strange and does not correctly update.
What do you mean by "strange"? Does this bug reply only pertain to the Firefox Button?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> What do you mean by "strange"? Does this bug reply only pertain to the Firefox
> Button?

After drag and drop bookmark within the bookmark popup of Firefox Button,the dropped bookmark appears wrong position.
(Reporter)

Comment 3

8 years ago
This problem happens due to adding items into placesView, after construction of _placesView (new PlacesMenu).

              <menupopup id="appmenuBookmarkMenu_popup"
                         placespopup="true"
                         context="placesContext"
                         openInTabs="children"
                         oncommand="BookmarksEventHandler.onCommand(event);"
                         onclick="BookmarksEventHandler.onClick(event);"
                         onpopupshowing="BookmarksMenuButton.onPopupShowing(event);
                                         if (!this.parentNode._placesView)new PlacesMenu(event, 'place:folder=BOOKMARKS_MENU');
>>                                      this.appendChild(document.getElementById('appmenuBookmarkMenu_unsorted_seperator'));
>>                                      this.appendChild(document.getElementById('appmenuBookmarkMenu_unsorted-menuitem'));"
                         tooltip="bhTooltip"
                         popupsinherittooltip="true">
(Reporter)

Comment 4

8 years ago
Still happens on
http://hg.mozilla.org/mozilla-central/rev/198709160138
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100922 Firefox/4.0b7pre ID:20100922041040
blocking2.0: --- → ?
Target Milestone: --- → Firefox 4.0
blocking2.0: ? → betaN+
Keywords: regression
Bug 592900 probably fixes this.
it's also possible there is a bug due to hiding bookmarks toolbar submenu and separator, but we should fix the other bug before (as dolske said, it was wrong in the first place to use appendChild that way) and than test for that.
Depends on: 592900
As far as I can test everything seems to be working fine after the patch in bug 592900, please reopen if you see remaining issues.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in bug 592900]
Target Milestone: Firefox 4.0 → Firefox 4.0b7
You need to log in before you can comment on or make changes to this bug.