Thunderbird does not autostart in KDE if it was running on logout/shutdown/restart

RESOLVED DUPLICATE of bug 508986

Status

()

RESOLVED DUPLICATE of bug 508986
8 years ago
8 years ago

People

(Reporter: gobzo, Assigned: orion)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100723 Fedora/3.6.7-1.fc13 Firefox 3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100720 Fedora/3.1.1-1.fc13 Thunderbird/3.1.1

Only Thunderbird does not autostart in KDE if it was running on logout/shutdown/restart


Reproducible: Always

Steps to Reproduce:
1. Start linux with KDE 4.4.5
2. Start Thunderbird
3. Log out
4. Log back in
Actual Results:  
All application which were running on logout will automatically start except for Thunderbird

Expected Results:  
Thunderbird should auto start if it was running on logout in KDE

Comment 1

8 years ago
I think the problem is that KDE restores the session by the executable name, which is thunderbird-bin rather than thunderbird. Thus, when logging in again, tunderbird-bin may not be in the path (and it shouldn't be the path to call
anyway as the thunderbird script does a couple of necessary setup actions).

You can try the following as a workaround to verify that theory:

1) In a konsole window, type "which thunderbird" to get the full path

2) assuming that you have /usr/local/bin/ in your path, make a symlink with
   ln -s /usr/bin/thunderbird /usr/local/bin/thunderbird-bin

Now try again and see if it resolves the issue (this assumes in #2 that your thunderbird path is /usr/bin/thunderbird, it may be different). If you don't have /usr/local/bin in your path (or don't want it there), you can also put thunderbird-bin into /usr/bin as a symlink to the thunderbird startup script.
(Reporter)

Comment 2

8 years ago
Your workaround worked just as you described.

Comment 3

8 years ago
Wayne, any suggestion how to resolve this bug? It seems to be more an issue
with proper packaging by the Linux distributors, and they should take care of
an applicable thunderbird-bin symlink to make it work with KDE; or, one could claim KDE has a problem here but not correctly taking note of the executable
and its environment variables when setting up a session. Either way, not much
that could be done from Thunderbird's side as it's a desktop-management issue.

Comment 4

8 years ago
caillon, matej, any suggestions? ...

(In reply to comment #3)
> Wayne, any suggestion how to resolve this bug? It seems to be more an issue
> with proper packaging by the Linux distributors, and they should take care of
> an applicable thunderbird-bin symlink to make it work with KDE; or, one could
> claim KDE has a problem here but not correctly taking note of the executable
> and its environment variables when setting up a session. Either way, not much
> that could be done from Thunderbird's side as it's a desktop-management issue.

Comment 5

8 years ago
No, this is our actually a bug in Thunderbird (and it was a bug in Firefox), that its registration with system is not compliant with XSMP. Our bug (in See Also bugs) mentions Mozilla bug 541806 (duplicate of the following), bug 508986 (fixed for Firefox, see http://hg.mozilla.org/mozilla-central/rev/16d4bba25a84), and bug 93789 (fixed as well, not sure what the patch is).

Updated

8 years ago
Duplicate of this bug: 609635
(Assignee)

Comment 7

8 years ago
Created attachment 488283 [details] [diff] [review]
Patch to always call gnome_client_set_restart_command in save_yourself_cb

This fixes my issue with not saving on "save session".  May fix others as well.

$ grep thunderbird ~/.kde/share/config/ksmserverrc 
command1=thunderbird
program13=thunderbird-bin
restartCommand13=/usr/bin/thunderbird,--sm-config-prefix,/thunderbird-bin-pRBSHh/,--sm-client-id,106f726361000128889890400000027610035,--screen,0

Comment 8

8 years ago
Confirming per previous comments. Orion, do you want to take this bug since you posted a patch already, and was that to be considered a draft only?
Status: UNCONFIRMED → NEW
Component: OS Integration → Startup and Profile System
Ever confirmed: true
Product: Thunderbird → Toolkit
QA Contact: os-integration → startup
(Assignee)

Comment 9

8 years ago
I'm not a mozilla developer, so I can't take the bug.  Someone definitely should review the patch as I don't know what the rest of save_yourself_cb is doing.  It also needs to be tested in the normal logout/restore scenario.  It may be that it never gets called with shutdown=TRUE, which might be causing other problems.  I hope to test that shortly.

Comment 10

8 years ago
I've assigned it to you, thus you should have full control on the bug now. The requests for bug 508986 may be a good reference for who can review your patch.
Assignee: nobody → orion
(Assignee)

Comment 11

8 years ago
Actually, I think this is just a dupe of bug 508986, and it appears to have a better patch.  I'm running 3.1.6 (1.9.2) though which doesn't have it.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508986

Comment 12

8 years ago
The patch for bug 508986 landed on mozilla-central only, not on mozilla-1.9.2 which would be needed to make it visible in TB 3.1.x (I assumed that your patch was supposed to go on top of Wolfgang's solution in the other bug...).
You need to log in before you can comment on or make changes to this bug.