bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Files downloaded from sedar.com have '.do' extension, so they aren't opened with the correct program

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Eggert Peterson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

Sedar has a distorted character test requiring one to enter the correct characters before allowing entry to the site. I get an error message " /users/eggertpeterson/downloads/CheckCode-1.do could note be opened because of an unknown error".
I go inside downloads and click on CheckCode-1.do and get the message "There is default application to open the document CheckCode-1.do.
I am able to access the site no problems using Safari.

I also accessed the site no problems using Firefox under Windows XP until my computer blew up a couple of months ago (hence the switch to Mac).

Reproducible: Always

Steps to Reproduce:
1.Open the Sedar site and follow the steps 
2.I have tried with different corporate names, so it is not just a fault of the one entry.
3.
Actual Results:  
Get an error message as described above.

Expected Results:  
Should have opened the corporate document I had specified

Comment 1

8 years ago
"follow the steps" is not specific enough for anybody to try and reproduce the problem. Can the problem be reproduced by other people without an account (or with a test account)? Please provide the detailed steps, if so.
Whiteboard: [closeme 2010-10-03]

Comment 2

8 years ago
From private e-mail (please post to the bug instead to keep everyone posted):
> There's no account required. SEDAR is the public information site of the 
> Ontario Securities and Exchange Commission where ALL publicly traded 
> companies'  documents are filed, so it's open to everybody. So to test 
> the bug just go to SEDAR's web site, pick a company (e.g. Royal Bank of 
> Canada, Suncor, Teck Cominco, Canadian Tire, etc.etc.), and "follow the 
> yellow brick road" to get access say to their last annual report, or most 
> recent press release, or whatever. Along the way you will be presented with 
> the distorted characters as a check against spamming or something, and 
> asked to enter the characters from the keyboard to prove there's a human 
> on the end..and TILT!

I actually was looking for detailed steps like this:
1. Open http://www.sedar.com/DisplayCompanyDocuments.do?lang=EN&issuerNo=00009209
2. Click "Final Receipt"
3. In the pop-up window enter the characters displayed in the CAPTCHA (case-sensitive!)

Actual results: after entering the correct letters, I am presented with the standard download "Opening CheckCode-1.do" dialog (with options Cancel and Save file).

Expected results (also happens in other browsers): ???

When you write it down like this, it makes much easier to try to reproduce the bug and answer you.

For instance with the steps above, I get the same results in both Firefox (Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b6pre) Gecko/20100904 Firefox/4.0b6pre) and Safari.

The file is saved successfully to the default download folder. It has a poor extension, but that's what the server sends us. I opened the downloaded file with OpenOffice successfully, you could also rename it to the correct extension to be able to double-click to open.
(Reporter)

Comment 3

8 years ago
Nick:

Sorry if I was a bit cavalier. 
My machine is a Mac with osX Snow Leopard, on which I have  a partition with Windows Vista (my old machine which blew up in June was MS and I had to set up a second OS so I could continue to use  too many valuable legacy programs). I have just tried the Sedar site on the Windows OS with Internet Explorer and everything works fine. I then went back into native Mac and tried the Sedar site using Safari and everything worked fine. But in Mac with Firefox:
1, Enter sedar.com/
Select English language and 

2. get sedar/com/issuers/company/_issuers_t_en.htm
3. Select The Toronto-Dominion Bank
4. Get sedar.com/displayprofile.do/?lang=EN&issuertype=03&issuerno=00001369.

((Note the .do suffix in the URL - this is what seems to give trouble later))

5. Click "view This company's documents"
The list of company's documents in reverse date order comes up on screen.
6. Click on "News Release - English" dated 2 Sept 2010.
7. Box display comes up: "Download SEDAR filings/Code verification and accept terms of use"
8. Read distorted alphanummeric code in box and enter , in instant case j7C4y.
Click accept. ((This is now where Firefox diverges from Safari and Internet 
Explorer, because with them, the desired document now comes on the screen.)) With Firefox:
9.Download page appears with box on it "CheckCode.do may be an application. It was downloaded from the internet and will be opened by Microsoft Word. Are you sure you want to open it?" boxes for Open, Cancel((In smaller letters at bottom of box. "Firefox.app downloaded this file today at 12::00pm"))
10. Click Open, MS word opens, and hangs. Go to Word, Box opens "Word cannot open this document. The document might be in use or might not be a valid Word document. (CheckCode.do)"

Hope this helps.

Eggert Peterson
(Reporter)

Comment 4

8 years ago
Oops, my bad.
My MS OS is XP not Vista.

Eggert Peterson

Comment 5

8 years ago
Thanks for the detailed followup!

In the case you described (the correct URL of the documents page at step 5-6 is http://sedar.com/DisplayCompanyDocuments.do?lang=EN&issuerNo=00001369 ) I get the same results as you do.

The difference between Safari and Firefox in handling this particular file is that Safari opens PDF in-browser, while Firefox doesn't do this by default. On Windows you probably have Adobe Reader installed, it makes PDF open in the browser too.

I guess the reason Word couldn't handle it is also that the file is a PDF, not a DOC.

You can install https://addons.mozilla.org/en-US/firefox/addon/7518/ to get PDF displayed right in Firefox on Mac. The site works as you expect (for PDF files) if you do.

I agree this is suboptimal experience for the Mac user, but I don't think Firefox could do anything to make it better. (Apart from including native PDF support.)

You do have ".do" files downloaded for "doc" files in Internet Explorer and Safari, right?
Summary: entering correct characters for distorted character test to enter site produces error message → Files downloaded from sedar.com have '.do' extension, so they aren't opened with the correct program
(Reporter)

Comment 6

8 years ago
The add-on patch works perfectly...Problem solved. Thanks to all

But I wonder why Firefox can't incorporate the add-on in the basic distribution to avoid this rather unnecessary glitch.

Eggert Peterson

Comment 7

8 years ago
Thanks for your cooperation. I'm closing this bug as invalid (= isn't a Firefox problem).

There's bug 91559 about handling PDF out of box on Mac. I expected that we're opposed to including PDF handling for philosophical reasons (not a web format), but judging from the comments there, it's just a question of implementing it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Whiteboard: [closeme 2010-10-03]
You need to log in before you can comment on or make changes to this bug.