Open pdf attachment in mail, no window displays

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: selmer, Assigned: mscott)

Tracking

({regression})

Trunk
x86
Windows NT
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
11/1 limbo2

I have an email with a pdf document attached.  When I use the paperclip button
to open it and click on the open it radio button, acrobat reader is launched.
However, it never shows up in the task bar, never displays in any NS6 window,
and never opens its own window.  I had Scottip try this on his NT, he got a
reader window but no contents.  (He has a different version of the reader than
me, may be related to the difference.
(Reporter)

Comment 1

18 years ago
I'm certain this used to work, marking regression and rtm.
Keywords: regression, rtm
(Assignee)

Comment 2

18 years ago
This is a dup of a bug andrei owns. the plugin code is jumpining on the pdf
content before the helper app code has a chance to be executed. I believe the
bug was futured for this release. Maybe av, remembers more. 
Assignee: mscott → av
(Reporter)

Comment 3

18 years ago
Damn!  I just didn't wait long enough.  I left my desk for a few minutes and the
acrobat window was up with the content when I returned.  On the other hand, I
tried to switch back to my inbox and the mail window hung :-(

Comment 4

18 years ago
The content should be displayed in the message body window like *.swf 
attachments do. Acrobat relies to StreamAsFile mechanism so it ignores the 
incoming stream and waits for the local file to be ready. Looks like 
nsImapProtocol.cpp does not have all the necessary stub implementations. The on 
we need for Acrobat is:

NS_IMETHODIMP
nsImapMockChannel::GetLocalFile(nsIFile* *file)
{
    NS_NOTREACHED("GetLocalFile");
    return NS_ERROR_NOT_IMPLEMENTED;
}

Changing product to mail-news.
Component: Browser-General → Networking - IMAP
Product: Browser → MailNews

Updated

18 years ago
Assignee: av → mscott
QA Contact: doronr → esther

Comment 5

18 years ago
Reassigning to default owner.
(Reporter)

Comment 6

18 years ago
rtm- based on mscott's comment
Whiteboard: [rtm-]

Comment 7

18 years ago
Changing qa assign
QA Contact: esther → pmock

Comment 8

18 years ago
*** Bug 65588 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Assign it to myself
QA Contact: pmock → fenella
(Assignee)

Comment 10

18 years ago
this is working for me but I don't have a plugin for acrobat to get in the way.
I think when selmer ran into this he was using the plugin. Steve, is that true?
If not, this may be a WFM now.
(Reporter)

Comment 11

18 years ago
Using 1/26 MTEST build, I still have the original behavior.  I don't have any
trunk builds installed yet, I'll have to give that a spin.

Comment 12

18 years ago
To Esther ..
QA Contact: fenella → esther
(Reporter)

Comment 13

18 years ago
OK, on 3/8 04 build (was 09 build on sweetlou?) I still have the problem.  Use
paper clip to open PDF attachment, acrobat launches, nothing in taskbar, no
window shows up, mail UI frozen (browser works) for a long time.  Eventually,
mail UI comes back and it's as though I never clicked anything.  I don't see an
acrobat process in the task manager.
Keywords: rtm → nsdogfood
Whiteboard: [rtm-]
*** Bug 71675 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 85640 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
This is what happens for me with build 20011018:
1. recieving a mail with a pdf attachment
2 [details] [diff] [review]. docuble click on the pdf attachment
3 [details] [diff] [review]. acrobat reader (5.0) is launched (splash screen showed)
4. mozilla downloads the attachment in the message pane
5. pdf document (acrobat reader) is shown in the message pane.

so basiclly worksforme...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
QA Contact: esther → trix

Comment 17

17 years ago
verified wfm
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

17 years ago
On win98, I get the right behavior.  On NT, the reader doesn't show up in my
message pane, instead it launches as a separate app window.  Is that what's
expected?  Is there some config thing I need to do so it shows up in the message
pane?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.