Closed Bug 589254 Opened 14 years ago Closed 14 years ago

"Unsorted Bookmarks" in "Firefox Menu Button" should open regular menu popup instead of Library

Categories

(Firefox :: Menus, enhancement)

x86
Windows 7
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 626852

People

(Reporter: alice0775, Unassigned)

References

Details

(Whiteboard: [wontfix?])

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100820 Minefield/4.0b5pre ID:20100820074529
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100820 Minefield/4.0b5pre ID:20100820074529

"Unsorted Bookmarks" in "Firefox Menu Button" opens Library instead of menu popup
It should be opened as regular menu.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Add adequate number of bookmarks into "Unsorted Bookmarks"
3. Click "Firefox Button"
4, Open Bookmarks popup (Bookmarks >)
5. Click "Unsorted Bookmarks"

Actual Results:
 Library window appears

Expected Results:
 Should be opened as regular menu
This is the intended behavior.
Severity: normal → enhancement
Summary: "Unsorted Bookmarks" in "Firefox Menu Button" opens Library instead of menu popup → "Unsorted Bookmarks" in "Firefox Menu Button" should open regular menu popup instead of Library
Whiteboard: [wontfix?]
@Joshua M
for me this is a useless behavior especially when you have large number of unsorted bookmarks
----------------
the "Unsorted Bookmarks" should behave like all other bookmark folders (opening a dropdown menu)
The reason this is the intended behavior is that the unsorted bookmarks folder is intended to hold potentially thousands of items (since you can now create a bookmark with a single click on the star icon).  Menus don't handle overflow very well when they are populated with a large number of items (hard to scroll, etc.)
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
Alex in light of your new bug 626852 should this be reopened and dupped to that?
>Alex in light of your new bug 626852 should this be reopened and dupped to
>that?

sure
Resolution: WONTFIX → DUPLICATE
You need to log in before you can comment on or make changes to this bug.