BCC-recipients are not displayed to me in sent mails which is saved in [Gmail]/Sent Mail by Gmail's STMP server

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
7 years ago
2 years ago

People

(Reporter: dfghjkjhg, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

User Story

Following is Bug 450368 Comment #4.
This is design of Gmail, so closed as Invalid.

     (A) mail data passed to SMTP     : no   BCC:, no   Received:, ...  
  == (B) sent mail copy saved in Sent : with BCC:, no   Received:, ...
  == (C) arrived mail to Gmail        : no   BCC:, with Received:, ...
It produces user's confusions.

(Confusion-1)
If Gmail's SMTP is used, (A) is written by Gmail's SMTP+Gmail first (in [Gmail]/All Mail, [Gmail]/Sent Mail).
So, (B) by mail client including Tb is not kept by Gmail. Some peoples call it "loss of BCC: header" and consider it Tb's bug.
If myself is included in To:/CC:/BCC: of the mail, arrived mail of (C) is not kept by Gmail.

(Confusion-2)
If Gmail's SMTP is not used, (B) is wrtten by mail client(Tb) first (in [Gmail]/All Mail, [Gmail]/Sent Mail or something). So, if myself is included in To:/CC:/BCC: of the mail, arrived mail of (C) is not kept by Gmail.

(Confusion-3)
If Gmail's Web Interace is used for mail sending, (B) is wrtten by Gmail first (in [Gmail]/All Mail, [Gmail]/Sent Mail). So, if myself is included in To:/CC:/BCC: of the mail, arrived mail of (C) is not kept by Gmail, or Gmail won't add Gmail Label of "Inbox" to the mail.

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.8) Gecko/20100802 Lightning/1.0b2 Thunderbird/3.1.2

When I send a message to BCC-recipients, the sent message does not show me these BCC-recipients (I'll attach screenshots with examples).
So it's not possible for me to find out any more to which BCC-recipients I once sent this mail.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 467903 [details]
BCC not displayed in sent mail - example 1
(Reporter)

Comment 2

7 years ago
Created attachment 467905 [details]
BCC not displayed in sent mail - example 2
(In reply to comment #1)
> BCC not displayed in sent mail - example 1

Did you use Gmail's SMTP server to send the mail?
Mail in which folder? [Gmail]/Sent Mail?
Which folder do you set as "folder to save sent mail copy"?

Read bug 450368 comment #4, if you use Gmail's SMTP server,  please.
=> INVALID.
(Reporter)

Comment 4

7 years ago
> Did you use Gmail's SMTP server to send the mail?
Yes.

> Mail in which folder? [Gmail]/Sent Mail?
Yes.

> Which folder do you set as "folder to save sent mail copy"?
Since Google says on its help pages, that it's not necessary to save copies of sent e-mail within TB (because Google is doing this already), I did not set any folder within TB as "folder to save sent mail copy".
But I just did a test and set [Gmail]/Sent in TB as "folder to save sent mail copy".
But didn't have any impact. Same result as before.

> bug 450368 comment #4 sounds quite similar to my problem. But it's very technical... I am not sure if it is really the same.
But as far as I understand, my bug here is a bug in GMail and not in TB ?
(In reply to comment #4)
> But as far as I understand, my bug here is a bug in GMail and not in TB ?

No. Not bug of Gmail nor Tb. It can be called "restriction of Gmail by design".
(Reporter)

Comment 6

7 years ago
Okay, thanks for clarifying this.
Then I will close my bug report here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Blocks: 402793
Summary: BCC-recipients are not displayed to me in sent mails → BCC-recipients are not displayed to me in sent mails which is saved in [Gmail]/Sent Mail by Gmail's STMP server
Duplicate of this bug: 557560
Duplicate of this bug: 550573
User Story: (updated)
Depends on: 557560
No longer depends on: 557560
Duplicate of this bug: 693495
You need to log in before you can comment on or make changes to this bug.