Closed Bug 589410 Opened 9 years ago Closed 9 years ago

Direct2D: scrolling with Flash content produces graphic glitches

Categories

(Core :: Graphics, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 587508

People

(Reporter: bugs, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

On some sites with flash content and enabled Direct2D (directwrite=true; render-mode=6) I have graphic glitches if I'm scrolling (horizontally).


Reproducible: Always

Steps to Reproduce:
1. open the WDR Mediathek (see URL)
2. scroll horizontally

Reproducible: always
Actual Results:  
around the flash content the text of the articles are "double" and the pictures are "disturbed"

Screenshot:
http://www.album.de/bild/1824275/firefox-400-beta4-build3-error-01.cfm

Expected Results:  
like it is with Direct2D disabled

Software:
Windows 7 Ultimate x64
Adobe Flash Player 10,1,82,76
DirectX June 2010
Nvidia driver 197.45 (Microsoft update)
(I will test it with the august 2010 drivers if they are available)

Hardware
Gainward Geforce GT 240 Golden Sample
AMD Athlon 64 x2 BE 5400+


I will look for more example sites soon.
Sorry, I mean vertically not horizontally.

The same with:

Software:
Windows 7 Ultimate x64
Adobe Flash Player 10,1,82,76
DirectX June 2010
ATI Catalyst Driver 10.7 (AGP) + Stream SDK 2.1
(I will test it with Catalyst 10.8 drivers if they are available)

Hardware
Club3D HD4670 AGP (CGA-46724)
AMD Athlon 64 3200+ (Venice)
Yup, I see it for sure!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587508
You need to log in before you can comment on or make changes to this bug.