Flash content flickering

RESOLVED DUPLICATE of bug 589864

Status

()

RESOLVED DUPLICATE of bug 589864
8 years ago
7 years ago

People

(Reporter: icecold, Assigned: bas.schouten)

Tracking

({regression})

Trunk
All
Windows 7
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b5pre) Gecko/20100821 Minefield/4.0b5pre
Build Identifier: 

With latest build 20100821 when I go to some website that has flash, or when I watch videos on YouTube, flash content flickers. 
Mostly when you scroll.

Also I noticed flickering when switching tabs.

Reproducible: Always

Steps to Reproduce:
1. Use latest nightly build (20100821)
2. Go to YouTube and play some video.
3. Scroll page or just watch video.
Actual Results:  
Flash content was flickering.

Expected Results:  
It shouldn't flicker.

Direct2D enabled.

Comment 1

8 years ago
Regression pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4192ba38ebee&tochange=95a39e236cc4
Candidate bug:
Bug 582057 - Replace platforms widgets in content processes with cross-platform fake widgets
Bug 585817 - Avoid surface allocations on GetThebesSurface
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: unspecified → Trunk

Comment 2

8 years ago
Created attachment 468034 [details]
Flash rendering error on Kongregate

Flash rendering issue on Kongregate (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100821 Minefield/4.0b5pre ID:20100821040844).  Non-redrawn areas are always black.

Comment 3

8 years ago
Please change the title.  This bug is not caused by any of the decode-on-draw related checkins.  It happens regardless of whether decode-on-draw or image discarding is enabled.

Updated

8 years ago
Summary: Flash content flickering with decode on draw → Flash content flickering

Comment 4

8 years ago
Flicker:
Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100821 Firefox/4.0b5pre ID:20100821040844
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100821 Minefield/4.0b5pre ID:20100821040844

Not flicker on Linux build:
Mozilla/5.0 (X11; Linux i686; rv:2.0b5pre) Gecko/20100821 Minefield/4.0b5pre ID:20100821031041

Updated

8 years ago
Blocks: 582057
(Assignee)

Comment 5

8 years ago
Just as a note, as expected this occurs with windowed flash, not windowless flash.

Updated

8 years ago
Flags: wanted-fennec1.0?
Flags: in-testsuite?
Flags: in-litmus?
Component: General → Plug-ins
Flags: wanted-fennec1.0?
Flags: in-testsuite?
Flags: in-litmus?
QA Contact: general → plugins
blocking2.0: --- → ?
No flicker issues with D2D off -

Comment 7

8 years ago
(In reply to comment #6)
> No flicker issues with D2D off -

Flash window is flickering even without D2D for me, but only when scrolling in this case.
But with D2D, flickering is much easier to see.
(In reply to comment #5)
> Just as a note, as expected this occurs with windowed flash, not windowless
> flash.

Expected ?  How so... Expected is smooth playback of videos not corruption and flicker and odd things when trying to mouse around and find the controls for the video whe d2d is enabled. 

So, is this a d2d issue or something being brought to light when it is enabled? 
Title should be changed to show [D2D]- Flicker on embedded videos
(Assignee)

Comment 9

8 years ago
(In reply to comment #8)
> (In reply to comment #5)
> > Just as a note, as expected this occurs with windowed flash, not windowless
> > flash.
> 
> Expected ?  How so... Expected is smooth playback of videos not corruption and
> flicker and odd things when trying to mouse around and find the controls for
> the video whe d2d is enabled. 
Well, the changeset that caused the regression doesn't affect windowless plugin drawing - therefor it's expected that the regression only affects windowed plugins.

> 
> So, is this a d2d issue or something being brought to light when it is enabled? 
> Title should be changed to show [D2D]- Flicker on embedded videos

That's the question, from what Loic says it appears to be an issue anyway, brought to light by D2D, but I can't be sure until I've investigated more.

Comment 10

8 years ago
I don't think D2D is the root cause. The same type of flickering occurs when scrolling the page without D2D. You're probably seeing flickering on D2D without scrolling because this new bug is interacting with a previous unfixed D2D bug. Flickering (same type without D2D) does occur though under D2D while scrolling.
Hardware: x86 → All

Comment 11

8 years ago
This bug does not depend on D2D or even Windows Vista/7.  It is fully reproducible on Windows XP, which doesn't support all that.
This bug seems to be applicable only with the youtube player.

No problem with customized flash players on :
vimeo.com
dailymotion.com
cnn.com
Also affects hulu.com

Comment 14

8 years ago
(In reply to comment #12)
Also
top page of www.yahoo.co.jp
Popular free movie site  gyao.yahoo.co.jp
Another example:    http://www.weather.com/weather/map/interactive/07746 

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100822 Minefield/4.0b5pre - Build ID: 20100822040607
Forgot to mention that my toolbar will flicker on occasion as well as the contents of a sidebar.

Comment 17

8 years ago
Also happens on Windows XP without D2D

Comment 18

8 years ago
especially visible on this page, lot of flash apps long page http://www.zdf.de/

Comment 20

8 years ago
Affecting many flash components to the point of being unusable.  Scrolling or moving mouse would give epileptics seizures.

Win7 Ultimate x64, NV 9800GT, D2D NOT enabled

Not that I'm complaining, but is it just me or has the past week of FF4 nightlies seemed VERY unstable with many regressions or bug introductions?
(Assignee)

Comment 21

8 years ago
(In reply to comment #20)
> Affecting many flash components to the point of being unusable.  Scrolling or
> moving mouse would give epileptics seizures.
> 
> Win7 Ultimate x64, NV 9800GT, D2D NOT enabled
> 
> Not that I'm complaining, but is it just me or has the past week of FF4
> nightlies seemed VERY unstable with many regressions or bug introductions?

Hrm, that might be somewhat expected for D2D Enabled, simply since it's very hard to test across the diversity of hardware we see in the wild, but it's definitely not expected for D2D disabled ofcourse.

Are you sure it's disabled? (i.e. check about:support)

Comment 22

8 years ago
(In reply to comment #21)
> Hrm, that might be somewhat expected for D2D Enabled, simply since it's very
> hard to test across the diversity of hardware we see in the wild, but it's
> definitely not expected for D2D disabled ofcourse.
> 
> Are you sure it's disabled? (i.e. check about:support)

My bad, D2D is enabled.  I was looking at an about:config value which apparently no longer applies.
(Assignee)

Comment 23

8 years ago
(In reply to comment #22)
> (In reply to comment #21)
> > Hrm, that might be somewhat expected for D2D Enabled, simply since it's very
> > hard to test across the diversity of hardware we see in the wild, but it's
> > definitely not expected for D2D disabled ofcourse.
> > 
> > Are you sure it's disabled? (i.e. check about:support)
> 
> My bad, D2D is enabled.  I was looking at an about:config value which
> apparently no longer applies.

Yes, -1 selects the 'default' render-mode, which for people windows Vista or 7 with DirectX 10 hardware is Direct2D.

Updated

8 years ago
Duplicate of this bug: 589548
Blocking on this regression. Bas, this sounds like something you should work on, if not, please reassign appropriately.
Assignee: nobody → bas.schouten
blocking2.0: ? → betaN+
Please reopen if bug 589864 doesn't fix this.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589864
(Reporter)

Comment 27

8 years ago
Seems to be fixed. (on YouTube is ok) .
But checkout here: http://www.blic.rs/ scroll down on right side look for Canina flash ad. Try scrolling and you will see issue with that flash.

Comment 28

8 years ago
@ Oskar
Nope it seems fixed no issues also with this canina ad you talking about
(Reporter)

Comment 29

8 years ago
I think that Canina flash ad issue is related to https://bugzilla.mozilla.org/show_bug.cgi?id=587508.
You need to log in before you can comment on or make changes to this bug.