Closed Bug 589468 Opened 11 years ago Closed 9 years ago

Change "computer" to "device" in all strings regarding Firefox Sync

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: hubert+bmo, Assigned: ally)

References

Details

(Whiteboard: qa+)

Attachments

(3 files)

In Firefox Sync we use "computer" word in many places.

Since I can use Sync on mobile devices I assume that we should change a word "computer" to "device" in all places regarding Firefox Sync

An example:
browser/locales/en-US/chrome/browser/syncSetup.dtd

Actual Result:
<!ENTITY setup.choicePage.existing.label  "I'm already using &syncBrand.shortName.label; on another computer">

Expected Result:
<!ENTITY setup.choicePage.existing.label  "I'm already using &syncBrand.shortName.label; on another device">
Component: General → Firefox Sync: UI
Product: Firefox → Mozilla Services
QA Contact: general → sync-ui
Version: Trunk → unspecified
I have double checked the android dtd & the desktop dtd and there is no longer any mention of computer. If you find a particular instance, please reopen and I will fix. :)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Hmm... http://mxr.mozilla.org/mozilla-central/search?string=computer&find={dtd%2Cproperties}&findi=&filter=[sS]ync&hitlimit=&tree=mozilla-central

In most of cases it should be changed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
and now it is my problem. :)

Note that some of that mobile xul is deprecated so I do not intend to update those.
Assignee: nobody → ally
liuche: this contains android string changes, as discussed in irc

NB: 
- The naming in the list may look inconsistent, but I tried to keep within the style of a given file, and they are non consistent with each other.
- I updated references in comments to particular entities that need to be manually kept identical so that future localizers will not be confused. 
- String list & their transformations:
  1 syncTabsMenu.label -> syncTabsMenu2.label
  2 tabs.otherComputers.label -> tabs.otherDevices.label
  3 syncKey.page.description -> syncKey.page.description2
  4 syncKey.keepItSafe4.description ->syncKey.keepItSafe4a.description
  5 syncComputerName.label -> syncDeviceName.label;"
  6 syncComputerName.accesskey -> syncDeviceName.accesskey;"
  7 tabs.otherComputers.label -> tabs.otherDevices.label
  8 syncTabsMenu.label -> syncTabsMenu2.label): 
  9 syncComputerName.label -> syncDeviceName.label
 10 syncComputerName.accesskey ->  syncDeviceName.accesskey
 11 syncKey.page.description ->  syncKey.page.description2 
 12 localizations notes comment was changed so as not to confuse future readers
 13 setup.choicePage.existing.label -> setup.choicePage.existing2.label 
 14 choice2.merge.main.label -> choice2a.merge.main.label       
 15 choice2.client.main.label  ->   choice2a.client.main.label  
 16 choice2.server.main.label  -> choice2a.server.main.label    
 17 confirm.merge.label  ->   confirm.merge2.label    
 18 confirm.client2.label  ->   confirm.client3.label 
 19 confirm.client.moreinfo.label -> confirm.client2.moreinfo.label
 20 resetClient.change.label -> resetClient.change2.label 
 21 wipeClient.change.label -> wipeClient.change2.label   
 22 wipeRemote.change.label -> wipeRemote.change2.label   
 23 remote.missing.label -> remote.missing2.label 
 24 sync.subtitle.header.label -> sync.subtitle.header2.label
 25 sync.fallback -> sync.fallback2
 26 sync.update.remote -> sync.update.remote2
 27 sync.message.notabs -> sync.message.notabs2
Attachment #653646 - Flags: review?(mconnor)
Attachment #653646 - Flags: feedback?(liuche)
Comment on attachment 653646 [details] [diff] [review]
string renaming, part 1/1, v0

liuche & rnewman are on pto. Hey nalexander, want to look over the mobile strings? :D
Attachment #653646 - Flags: feedback?(nalexander)
Comment on attachment 653646 [details] [diff] [review]
string renaming, part 1/1, v0

Review of attachment 653646 [details] [diff] [review]:
-----------------------------------------------------------------

Everything looks fine but this needs to be landed on a-s github separately.  I'll prepare that and then we can land this as two patches, one for desktop, one for mobile.  Cool?
Attachment #653646 - Flags: feedback?(nalexander) → feedback-
Hi ally, moving on the Android Sync side of this.  How do we feel about:

<!ENTITY sync.subtitle.connectlocation.label 'Select “&sync.title.pair.label;” in the &syncBrand.shortName.label; section of your desktop Firefox options.'>

Strictly speaking, we should probably update this label to be device neutral as well.  How about:

'Select “&sync.title.pair.label;” in the &syncBrand.shortName.label; section of your other device's Firefox options.'
That works for me. It's a compromise, inevitably.
Status: REOPENED → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
(In reply to Nick Alexander :nalexander from comment #8)
> See https://github.com/mozilla-services/android-sync/pull/249 for a-s github.

ally: you want to r+ this?  I'll land on github and post the patch as part 1/2 here, then you can update your patch as 2/2 and we can land on m-i?
Nick, I can't r+ your patch, as I don't have peership, and my patch has yet to get an r+ from a desktop reviewer (in this case, mconnor).

Your changes sound fine to me, but my opinion doesn't mean anything official. :)
(In reply to Nick Alexander :nalexander from comment #10)
> (In reply to Nick Alexander :nalexander from comment #8)
> > See https://github.com/mozilla-services/android-sync/pull/249 for a-s github.
> 
> ally: you want to r+ this?  I'll land on github and post the patch as part
> 1/2 here, then you can update your patch as 2/2 and we can land on m-i?

r+.
Here's the Sync part of this.  It's been checked into github but hasn't been merged into m-i.
I tried to update your patch on top of this, but it really doesn't apply to m-i.  I'll let you handle that.
Comment on attachment 653646 [details] [diff] [review]
string renaming, part 1/1, v0

Review of attachment 653646 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/locales/en-US/chrome/browser/syncSetup.dtd
@@ +102,2 @@
>  
>  <!-- Confirm Merge Options -->

There's probably a followup in here about how this and the syncSetup.properties changes make inconsistent use of the brand substitution stuff.  not a priority, but should file for when we revisit this UI.

::: mobile/android/locales/en-US/chrome/sync.properties
@@ +30,4 @@
>  sync.setup.tryagain=Try again
>  sync.setup.manual=Manual setup
>  
> +sync.message.notabs2=No tabs from your other device(s).

I think "devices" is sufficient here.  The (s) seems awkward, and I'd skip it.
Attachment #653646 - Flags: review?(mconnor)
Attachment #653646 - Flags: review+
Attachment #653646 - Flags: feedback?(liuche)
Please note that Nick landed the string I asked to be changed, so please fix before that merges to m-i
(In reply to Mike Connor [:mconnor] from comment #16)
> Please note that Nick landed the string I asked to be changed, so please fix
> before that merges to m-i

Just to be clear: I did not land anything on any HG tree.  The patch I posted has landed on android-sync github and needs to be committed to m-i (or s-c, I suppose) with the desktop changes.
I pulled the mobile changes from my patch, and marked my patch as 1/2. Nick, when gps gets in, we'll try the coordination dance.
since my account is currently disabled, someone else will have to land
Whiteboard: qa+
https://hg.mozilla.org/mozilla-central/rev/82bf0d1d370b
https://hg.mozilla.org/mozilla-central/rev/e874ca7eba4a
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/syncSetup.dtd#105

confirm.merge2.label    "&syncBrand.fullName.label; will now merge all this device's browser data into your Sync account.

Shouldn't it be &syncBrand.fullName.label; instead of Sync here?
(In reply to Francesco Lodolo [:flod] from comment #22)

> Shouldn't it be &syncBrand.fullName.label; instead of Sync here?

shortName, perhaps. But this bug was quite limited in scope.
Duplicate of this bug: 694278
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.