Closed Bug 589564 Opened 10 years ago Closed 8 years ago

(ietestcenter) HTML5 Media Elements 11/23: 'application/octet-stream' is not a type the UA cannot render.

Categories

(Core :: Audio/Video, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 567077

People

(Reporter: darxus-mozillabug, Assigned: cpearce)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre
Build Identifier: 

Failed test.

Reproducible: Always
Blocks: ietestcenter
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Component: General → Video/Audio
Ever confirmed: true
OS: Linux → All
QA Contact: general → video.audio
Hardware: x86_64 → All
Depends on: 546129
Pretty sure the test is backwards.  The code is:

var vid = document.createElement("video");

if (vid.canPlayType("application/octet-stream") != "")
{
    passTest();
}

I'm pretty sure that test should be == based on the spec:

http://www.w3.org/TR/html5/video.html#dom-navigator-canplaytype
This sentence needs more negatives:

"The MIME type "application/octet-stream" with no parameters is never a type that the user agent knows it cannot render. User agents must treat that type as equivalent to the lack of any explicit Content-Type metadata when it is used to label a potential media resource."

IE9 preview responds with "maybe".  After reading this 12 times it sounds like application/octet-stream is special.  So I guess we should do the same here?
Assignee: nobody → chris
See this long thread:

<http://lists.whatwg.org/htdig.cgi/whatwg-whatwg.org/2010-July/027169.html>

There is, as far as I know, still discussion going on as to how exactly to treat application/octet-stream. All the browsers currently differ.
We should not change any of our sniffing/type-handling behaviour until the spec stabilizes more.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #5)
> We should not change any of our sniffing/type-handling behaviour until the
> spec stabilizes more.

Since Fx18, video with mime type application/octet-stream can be played, but I cannot find a corresponding bug. The said spec stablized or it happend unintentionally? Thanks!
(In reply to Hector Zhao [:hector_zhao] from comment #6)
> 
> Since Fx18, video with mime type application/octet-stream can be played, but
> I cannot find a corresponding bug. The said spec stablized or it happend
> unintentionally? Thanks!

Bug 567077.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 567077
You need to log in before you can comment on or make changes to this bug.