Closed Bug 589585 Opened 10 years ago Closed 9 years ago

Intermittent failure in test_classifier.html | Should not load bad javascript - got "loaded malware javascript!", expected "untouched", followed by bad css

Categories

(Toolkit :: Safe Browsing, defect)

x86
Windows CE
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jdm, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [should be fixed by 594882])

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282499138.1282499927.27844.gz
Rev3 WINNT 6.1 mozilla-central opt test mochitests-5/5 on 2010/08/22 10:45:38

s: talos-r3-w7-049
6533 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/components/url-classifier/tests/mochitest/test_classifier.html | Should not load bad javascript - got "loaded malware javascript!", expected "untouched"
6534 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/components/url-classifier/tests/mochitest/test_classifier.html | Should not load bad css - didn't expect "hidden", but got it
Blocks: 438871
OS: Linux → Windows CE
Whiteboard: [orange]
This test is a bit scary, and hasn't changed in over a year.  Looks pretty bad that it's failing.

Mossop, you touched this most recently (last june :)) - any thoughts on what might be going wrong / what change might've caused this / who might know more?
Requesting blocking2.0, since this test-failure's message looks like something we'd really prefer not to break in a new Firefox version. :)
blocking2.0: --- → ?
The fact that this only started failing around the 22nd makes me wonder if something we checked in around that date is the cause.
Shawn - bit of a longshot, but is there any plausible reason this might be related to sqlite changes?
Depends on: 594882
sdwilsh - reping re comment 6?
(In reply to comment #11)
> sdwilsh - reping re comment 6?

This is not sqlite related, see bug 594882.
Yeah, clearing the blocker nom here - bug 594882 is the important one. This is just a bug that gives people something to use when starring.
blocking2.0: ? → ---
Whiteboard: [orange] → [orange][should be fixed by 594882]
No more reports, marking as fixed.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [orange][should be fixed by 594882] → [should be fixed by 594882]
Erm... No reports in over 2 years, and then 2 failures in 1 day. looks like this regressed today?

I'm going to file a new bug, because this one was (reportedly) fixed by an actual commit (per whiteboard status "should be fixed by bug 594882".
I filed bug 823820 for comment 15 and comment 16, but then I noticed that both failures were from a busted phishing-protection-related push that was backed out. (as noted in bug 823820 comment 1. See also bug 820283 comment 35.)

So -- nothing to worry about, carry on.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.