Open Bug 589589 Opened 9 years ago Updated Last month

[meta] Breakdown: Chrome profile migration for Import Wizard and Migration Assistant - passwords, form data, and settings

Categories

(Firefox :: Migration, defect)

defect
Not set

Tracking

()

People

(Reporter: asa, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: meta, Whiteboard: p=)

New Firefox profiles should offer to migrate Google Chrome settings and data including at least bookmarks, passwords, history, form data, & cookies, and if possible also search services, keywords, tags, pop-up settings, cookie settings, page zoom levels, geolocation permissions, storage permissions, window size and position, toolbar visibility and ordering, proxies, malware settings, and tab opening order/position settings.

(This is not a duplicate of bug 505192 which is about the Import feature and specific to Chrome bookmarks.)
OS: FreeBSD → All
The patch in bug 505192 covers a chrome profile migrator (it does more than just bookmarks), so I think this can probably just be a dupe.
Does that other bug also cover making it a migration feature and not just an import feature?
I'm not sure the distinction you're drawing - we only have "migrators", and that list determines the sources available from both the "File->Import" and first-run auto-import features. That bug is about adding a Chrome migrator.
There are two features that depend on migrators, Import, and Migration Assistant. I don't care about the Import Wizard feature (I'm sure someone does, though) but the Migration Assistant needs to include Chrome.

If that bug is about creating the migrators, then we probably need two additional bugs, one for adding Chrome to the Migration Assistant (this bug) and one for adding Chrome to the Import Wizard.
All migrators are included in both the "Import" and "Migration" wizards automatically, there's no need to "add" them.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 505192
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
m_kato@ga2.so-net.ne.jp says the other bug is just for cookies, bookmarks, and history. We have to have passwords too and if at all possible we should also get form data and common prefs too.  Re-opening this to cover those.
Status: REOPENED → NEW
Depends on: 505192
Summary: firefox migration assistant should offer to migrate google chrome settings and data → Chrome profile migration for Import Wizard and Migration Assistant - passwords, form data, and settings
password is into "Login Data".  But password value into this SQLite database is encrypted by 3DES.  I don't investigate how to get master key yet.
settings is into "Preferences".  It is JSON file, but I don't have mapping Firefox settings vs Chrome settings.
forms is into "Web Data".

After landing bug 505192, I will take this bug.
Makoto, is this something you're still working on? These are important migrators, especially passwords. We can leave off the "settings" migrator until later (I want us to migrate a few key settings like "Always show the bookmarks bar", pinned tabs, and download location.)
(In reply to Asa Dotzler [:asa] from comment #9)
> Makoto, is this something you're still working on? These are important
> migrators, especially passwords. We can leave off the "settings" migrator
> until later (I want us to migrate a few key settings like "Always show the
> bookmarks bar", pinned tabs, and download location.)

password is bug 707044.   I can import http auth, but form login doesn't work correctly.  I am still investigating this...
btw, please wait for bug 718608 to land, or we are going to do the work twice.
Depends on: 718608
Whiteboard: [feature] p=0
(In reply to x.redir from comment #12)
> Today I can see that Firefox has implemented a similar Sync feature as
> Chrome, and I would like to switch back to Firefox. How could I do that
> without loosing the past 2 years of browsing data?

The current Chrome migrator, that you can reach on first run of Firefox or from the Library (Show All Bookmarks) window, can currently import cookies, bookmarks, and history (bug 946757 seems to point out we are missing some, but I didn't have a chance to check yet), at least from 2011. Surely it would be nice to import other data as requested here, that's planned, but I can't give you an eta, our resources are limited.
Flags: needinfo?
No longer blocks: fxdesktopbacklog
Whiteboard: [feature] p=0 → p=0
Marco, do you think this should be on the desktop backlog?
Flags: firefox-backlog? → firefox-backlog+
I'm thinking we should split this into separate bugs. Bug 707044 covers passwords on Windows (and Linux?), I have an investigation bug open for passwords on OS X (bug 1018667), and I think form data and settings can be split into their own bugs (or morph this into one of them).
Depends on: 707044
(In reply to Matthew N. [:MattN] from comment #19)
> I'm thinking we should split this into separate bugs.

very likely, this needs a breakdown.
Depends on: 1019006
No longer depends on: 1019006
Duplicate of this bug: 1019006
QA Whiteboard: [qa-]
Keywords: meta
Summary: Chrome profile migration for Import Wizard and Migration Assistant - passwords, form data, and settings → Breakdown: Chrome profile migration for Import Wizard and Migration Assistant - passwords, form data, and settings
Whiteboard: p=0 → p=
Depends on: 1513718
Summary: Breakdown: Chrome profile migration for Import Wizard and Migration Assistant - passwords, form data, and settings → [meta] Breakdown: Chrome profile migration for Import Wizard and Migration Assistant - passwords, form data, and settings

There is a way to import your Chrome passwords to Firefox: https://github.com/louisabraham/ffpass
A tutorial can be found here: https://dev.to/thebabscraig/from-chrome-to-firefox-quantum-in-4-easy-steps--5572

But it would be very nice if this would be easier - the normal user will struggle using the terminal. Chrome can export the passwords into a .csv file, why is there no easy way to import this simple file into Firefox on Mac? As I understand it is possible on Windows.

The switch to Firefox from Chrome should be as easy as possible in my humble opinion.

Chrome can export the passwords into a .csv file, why is there no easy way to import this simple file into Firefox on Mac?

There is now! 😅 You can import passwords from Chrome on macOS in Nightly and Beta; Matt implemented that in bug 1423714. It'll be available in Firefox 70 release on October 22!

You need to log in before you can comment on or make changes to this bug.