If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[SeaMonkey 2.1, mochitest-chrome, intermittent] test_action_keys_respect_focus.xul | Test timed out.

VERIFIED DUPLICATE of bug 515407

Status

SeaMonkey
Download & File Handling
VERIFIED DUPLICATE of bug 515407
7 years ago
7 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

({assertion})

Trunk
assertion

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1282499502.1282502435.6363.gz

7245 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/suite/common/downloads/tests/test_action_keys_respect_focus.xul | Test timed out.

A failure in suite code. Scary, might be an actual failure!
(Reporter)

Updated

7 years ago
Blocks: 452942
(Reporter)

Updated

7 years ago
Component: Testing Infrastructure → Download & File Handling
QA Contact: testing-infrastructure → download
(Reporter)

Updated

7 years ago
Summary: [SeaMonkey 2.1, mochitest-browser-chrome] test_action_keys_respect_focus.xul | Test timed out. → [SeaMonkey 2.1, mochitest-chrome] test_action_keys_respect_focus.xul | Test timed out.
(Reporter)

Comment 1

7 years ago
Seems to be intermittent, and I've only seen it on a Linux run.
Summary: [SeaMonkey 2.1, mochitest-chrome] test_action_keys_respect_focus.xul | Test timed out. → [SeaMonkey 2.1, mochitest-chrome, intermittent] test_action_keys_respect_focus.xul | Test timed out.
Whiteboard: [sm-perma][orange] → [orange]
Duplicate of bug 515407 !?

*****

Full log has interesting lines:
{{
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/toolkit/components/downloads/src/nsDownloadManager.cpp, line 1459

WARNING: Context has no global.: file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/dom/base/nsJSEnvironment.cpp, line 2518

###!!! ASSERTION: Empty aExtension parameter!: '!aExtension.IsEmpty()', file /builds/slave/comm-central-trunk-linux-debug/build/mozilla/uriloader/exthandler/nsExternalHelperAppService.cpp, line 2892
nsExternalHelperAppService::GetTypeFromExtras(nsACString_internal const&, nsACString_internal&) [uriloader/exthandler/nsExternalHelperAppService.cpp:2895]
nsExternalHelperAppService::GetTypeFromExtension(nsACString_internal const&, nsACString_internal&) [uriloader/exthandler/nsExternalHelperAppService.cpp:2721]
nsIconChannel::InitWithGnome(nsIMozIconURI*) [modules/libpr0n/decoders/icon/gtk/nsIconChannel.cpp:390]
nsIconChannel::Init(nsIURI*) [modules/libpr0n/decoders/icon/gtk/nsIconChannel.cpp:462]
nsIconProtocolHandler::NewChannel(nsIURI*, nsIChannel**) [modules/libpr0n/decoders/icon/nsIconProtocolHandler.cpp:115]
nsIOService::NewChannelFromURI(nsIURI*, nsIChannel**) [netwerk/base/src/nsIOService.cpp:609]
...
}}
Severity: normal → critical
blocking-seamonkey2.1: --- → ?
Keywords: assertion
(Reporter)

Comment 3

7 years ago
No test failure is critical unless we know that the product we ship is broken.

You're right with the dupe though, will adapt the summary there so I can find it correctly.
Severity: critical → normal
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 515407
V.Duplicate, then.
No longer blocks: 452942
Status: RESOLVED → VERIFIED
Whiteboard: [orange]
blocking-seamonkey2.1: ? → ---
You need to log in before you can comment on or make changes to this bug.