Closed Bug 589651 Opened 9 years ago Closed 9 years ago

(ietestcenter) SVG 55/56: Test passes if there are fourteen blue shapes on the page.

Categories

(Core :: SVG, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: darxus-mozillabug, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre
Build Identifier: 

Missing one blue shape.

Reproducible: Always
Blocks: ietestcenter
Version: unspecified → Trunk
The pattern has no patternUnits or patternContentUnits specified, which means the former defaults to objectBoundingBox and the latter defaults to userSpaceOnUse per spec.  Since the relevant markup is:

     <pattern id="testPattern" width="100" height="100" viewBox="0 0 100 100">
       <rect width="100" height="100" fill="blue" />
     </pattern>
     <rect fill="url(#testPattern)" x="240" width="100" height="100" />

this defines a pattern that's 10000x10000px which has a single 100x100 blue square in it.  Then we fill with that pattern... the only question is what that should do.  I assume the test meant to use patternUnits="userSpaceOnUse", but it doesn't actually do that.
Component: General → SVG
QA Contact: general → general
Depends on: 633337
Status: UNCONFIRMED → NEW
Ever confirmed: true
There are 14 shapes now. I think Microsoft has changed the test though. The original test should be fixed by the check in for bug 633337.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.