Last Comment Bug 589654 - (ietestcenter) CSS3 Fonts 3/13: font style descriptor
: (ietestcenter) CSS3 Fonts 3/13: font style descriptor
Status: RESOLVED FIXED
:
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: All All
: -- normal
: ---
Assigned To: english-us
:
Mentors:
http://samples.msdn.microsoft.com/iet...
Depends on:
Blocks: ietestcenter
  Show dependency treegraph
 
Reported: 2010-08-22 18:23 PDT by Darxus
Modified: 2015-04-19 23:39 PDT (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Darxus 2010-08-22 18:23:36 PDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre
Build Identifier: 

1) Third line is same as first two.
2) No slant.

Reproducible: Always
Comment 1 philippe (part-time) 2010-08-23 05:04:20 PDT
Isn't this invalid ?
Comment 2 John Daggett (:jtd) 2010-08-24 03:52:01 PDT
Yeah, this test is invalid.  I sent a mail to some of the MS QA guys.

The test defines a font family with a single italic face, then tries to compare between the behavior when different font-style attributes are used.  There are a few problems with this.

1. If a family includes a single italic face, independent of the setting of font-style, that face will be used.

2. Style matching with @font-face runs is done based on the values of the descriptors, *not* based on the style data in the font.  So in this case the normal face of Arial will be treated as italic.  No synthetic obliqueing should happen in this case.

3. For font selection, italic and oblique are effectively synonymous.  With @font-face you technically could define separate italic and oblique faces that *should* match on or the other but I doubt there are implementations that do this correctly (I know Gecko has lots of "if italic or oblique..." logic).

4. The test also assumes Arial is the default font.
Comment 3 Darxus 2010-08-24 09:39:23 PDT
This shouldn't be closed until the MS test is fixed, per several other similar bugs.
Comment 4 Lars Gunther 2010-08-24 10:12:57 PDT
I can't see why Mozilla should track MS bugs.
Comment 5 Boris Zbarsky [:bz] 2010-08-24 11:37:02 PDT
Because we need to make sure they fix this, because we get bad press for it.
Comment 6 jag (Peter Annema) 2011-02-10 20:09:33 PST
This test seems to have changed, and it appears we pass now.
Comment 7 Boris Zbarsky [:bz] 2011-02-10 20:15:29 PST
OK, good!

Note You need to log in before you can comment on or make changes to this bug.