Range insertNode not implemented

VERIFIED FIXED in mozilla0.9.1

Status

()

Core
DOM: Core & HTML
P1
normal
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: Dylan Schiemann, Assigned: anthonyd)

Tracking

({dom2, testcase})

Trunk
mozilla0.9.1
dom2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
BuildID:    20001031

insertNode DOM 2 Range method not yet implemented

Reproducible: Always
Steps to Reproduce:
1. attempt to insertNode in a Range returns not implemented error

Actual Results:  NS_ERROR_NOT_IMPLEMENTED

testcase to follow
(Reporter)

Updated

18 years ago
Priority: P3 → P5
(Reporter)

Comment 1

18 years ago
Created attachment 18614 [details]
testcase

Updated

18 years ago
Keywords: testcase

Comment 2

18 years ago
Reporter is this still a problem in the latest nightlies? It seems to work for
me in 2000120604. 
(Reporter)

Comment 3

18 years ago
It is still in the 20001211 nightly... Anthony is working on DOM Range bugs.
You will see the error message in tools -> JavaScript console.

Comment 4

18 years ago
Marking NEW as per reporters comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

18 years ago
setting milestone, and priority.
anthonyd
Status: NEW → ASSIGNED
Priority: P5 → P1
Target Milestone: --- → mozilla0.9

Comment 6

18 years ago
finishing up range can be pushed off
Target Milestone: mozilla0.9 → mozilla0.9.1
Keywords: dom2
Component: DOM Level 2 → DOM Traversal-Range

Comment 7

18 years ago
I am attaching a JavaScript "Patch" that can be used as a work around for the 
range object.  This patch adds support for the following:
    Range.innerHTML - read only
    Range.extractContents - as per W3C specs
    Range.cloneContents - as per W3C specs
    Range.insertNode - as per W3C specs
    Range.surroundContents - as per W3C specs
    Range.deleteContents - as per W3C specs - fixes buggy support from Mozilla
    Range.jmyCompareNode - extends Mozilla's compareNode to include
                           the following 2 constants
    Range.NODE_BEFORE_AND_INSIDE = -1;
    Range.NODE_INSIDE_AND_AFTER = -2;

I would like a C++ programmer to implement these in C if possible.

Jeff Yates

Comment 8

18 years ago
Created attachment 27461 [details]
Patch for Range functionality

Comment 9

18 years ago
Created attachment 27511 [details]
Updated patch with test cases and code commenting (had an error in surroundContent method)
(Assignee)

Comment 10

18 years ago
Jeff Yates,
It looks like you didnt specify the mime type for this patch you attached.  It 
just looks like garbage, can yuo reattach with mime type text please? Thanks.

anthonyd
(Assignee)

Comment 11

18 years ago
movign to mozilla 0.9
anthonyd
Target Milestone: mozilla0.9.1 → mozilla0.9

Comment 12

18 years ago
Created attachment 27651 [details]
Patch js file

Comment 13

18 years ago
Created attachment 27652 [details]
Test Case

Comment 14

17 years ago
moving to mozilla1.0
Target Milestone: mozilla0.9 → mozilla1.0

Updated

17 years ago
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: mozilla1.0 → mozilla0.9.1
(Assignee)

Comment 15

17 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

17 years ago
see 58969 for details

Comment 17

16 years ago
catching up on verifications
Status: RESOLVED → VERIFIED
Component: DOM: Traversal-Range → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.