Closed Bug 589751 Opened 12 years ago Closed 12 years ago

IDN domain names in Arabic under (xn--ygbi2ammx) (فلسطين) are not displayed in the Arabic Language (U-Label)

Categories

(Firefox :: General, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 576508

People

(Reporter: radwanm, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

When we put an Arabic IDN domain name under our new IDN ccTLD (xn--ygbi2ammx) it is displayed using the A-Label (Latin) representation not the native Arabic characters. This can be solved locally by modifying the about:config file. We hope that the Palestine (xn--ygbi2ammx) is included as part of the Network Whitelist. We are using the standard Code Points for the ARabic Language available at http://www.iana.org/domains/idn-tables/tables/sa_ar_1.0.html


Reproducible: Always

Steps to Reproduce:
1.type the following (IDN code) on the URL address box
http://موقع.هيئة-مسميات-الانترنت.فلسطين
Actual Results:  
http://xn--4gbrim.xn-----6sdbgbkkda0fr9tibwcc1dg.xn--ygbi2ammx/

Expected Results:  
http://موقع.هيئة-مسميات-الانترنت.فلسطين
There wasn't a separate bug yet, but it's mentioned in the 2nd attachment of bug 576508.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 576508
You need to log in before you can comment on or make changes to this bug.