Closed Bug 58986 Opened 20 years ago Closed 6 years ago

The Find dialog should show autocomplete with recent searches

Categories

(SeaMonkey :: Find In Page, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.25

People

(Reporter: aaronlev, Assigned: philip.chee)

References

Details

Attachments

(1 file, 2 obsolete files)

When bringing up the find dialog box, the last item searched for is there.
This is good, but it should be highlighted, so when you start typing a new find
string it replaces it, instead of being appended on the end of the last one.

Perhaps there should also be a drop down history list of previous searches.
Aaron, please file only one suggestion/bug per bug report.

Selecting the contents of the field when it is opened is a duplicate of bug 
28583. So I'll narrow this RFE down to providing a list of previous searches. 
Perhaps auto-complete for the field would suffice, but that wouldn't fill in the 
options that had been used with each previous search. Hmmmm.

See also bug 7930, where I specced a UI for more features for the Find dialog.
Summary: Improvements for Find dialog box → Menu of recent searches in Find dialog
Chaning the qa contact on these bugs to me. MPT will be moving to the 
owner of this component shortly. I would like to thank him for all his hard 
work as he moves roles in mozilla.org...Yada, Yada, Yada...
QA Contact: mpt → zach
Blocks: 70771
updating to new owner. sorry for the spam.
Assignee: hangas → mpt
*** Bug 118332 has been marked as a duplicate of this bug. ***
*** Bug 126155 has been marked as a duplicate of this bug. ***
My initial reaction: "yay, yet another thing to clear when I finish surfing
porn!"  But I do see how this could be useful... for example, I often search
bugs for my name.
*** Bug 150420 has been marked as a duplicate of this bug. ***
So? Mozilla 1.1a is "out" and history in "Find" is not there... :(
.
Assignee: mpt → blaker
Component: User Interface Design → XP Apps: GUI Features
QA Contact: zach → paw
*** Bug 213668 has been marked as a duplicate of this bug. ***
Reassigning obsolete bugs to their respective Seamonkey owners (i.e. nobody). 
If you want this fixed for Firefox, change the Product and Component accordingly
and reassign back to me.
Assignee: firefox → guifeatures
Product: Core → Mozilla Application Suite
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: pawyskoczka → guifeatures
Component: XP Apps: GUI Features → UI Design
Component: UI Design → Find In Page
Priority: P3 → P5
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #790786 - Flags: feedback?(neil)
+        <textbox id="dialog.findKey" flex="1"
+                 type="autocomplete"
+                 autocompletesearch="form-history"
+                 autocompletesearchparam="find-dialog"
+                 ontextentered="updateFormHistory();"
+                 oninput="doEnabling();"/>
I'm not using |enablehistory| but I'm getting a non-functional drop marker anyway that doesn't do anything. Might be due to the treeBoxObject errors I was getting when I was using the XPFE autocomplete.
Attachment #790789 - Flags: feedback?(neil)
Comment on attachment 790786 [details] [diff] [review]
Patch Cv1.0 comm-central part. Force the findDialog to use toolkit autocomplete.

What about Thunderbird?
> +  if (window.opener.gPrivate || !dialog.findKey.value) 
Whoops, gPrivate is SeaMonkey only
Comment on attachment 790789 [details] [diff] [review]
Patch Tv1.0 Toolkit Part. Use form history for the autocomplete source.

>@@ -95,16 +96,17 @@ function onAccept()
>+  updateFormHistory();
Probably don't need ontextentered in this case.

>+                 autocompletesearchparam="find-dialog"
Hmm, if you create a web page textbox with this name does it start autocompleting? (I seem to remember there being some weird workaround to stop search bar results appearing in web pages...)
(In reply to comment #17)
> (I seem to remember there being some weird workaround to
> stop search bar results appearing in web pages...)

nsFormAutoComplete.js, line 165:
if (aInputName == 'searchbar-history' && aField) {

Because of course satchel stores autocompletesearchparam="searchbar-history" data in the same place that it stores <input name="searchbar-history"> data...
I filed a bug on comment 17 and the response was a little non-committal...
(In reply to neil@parkwaycc.co.uk from comment #19)
> I filed a bug on comment 17 and the response was a little non-committal...

OK, so the response now seems to be that the bug needs to be fixed but not to worry about it.
Summary: Menu of recent searches in Find dialog → The Find dialog should show autocompete with recent searches
Changes since the last Toolkit patch:
1. ontextentered removed as it wasn't necessary.
2. It turns out that PrivateBrowsingUtils is imported from contentAreaUtils.js anyway so checking for SeaMonkey specific gPrivate wasn't necessary.

> +  if (window.opener.PrivateBrowsingUtils &&
> +      window.opener.PrivateBrowsingUtils.isWindowPrivate(window.opener) ||
> +      !dialog.findKey.value)
Attachment #790789 - Attachment is obsolete: true
Attachment #790789 - Flags: feedback?(neil)
Attachment #794079 - Flags: review?(neil)
Comment on attachment 790786 [details] [diff] [review]
Patch Cv1.0 comm-central part. Force the findDialog to use toolkit autocomplete.

Cancelling feedback? request as this patch isn't needed at the moment.
Attachment #790786 - Flags: feedback?(neil)
See Also: → 912693
Depends on: 911090
Summary: The Find dialog should show autocompete with recent searches → The Find dialog should show autocomplete with recent searches
Comment on attachment 790786 [details] [diff] [review]
Patch Cv1.0 comm-central part. Force the findDialog to use toolkit autocomplete.

Not needed.
Attachment #790786 - Attachment is obsolete: true
Sorry for the long wait.
Attachment #794079 - Flags: review?(neil) → review+
Pushed to mozilla inbound f69c9019e0b0
http://hg.mozilla.org/integration/mozilla-inbound/rev/f69c9019e0b0
https://hg.mozilla.org/mozilla-central/rev/f69c9019e0b0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.25
You need to log in before you can comment on or make changes to this bug.