Not able to select the audio device (2 soundcards)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: daniel, Unassigned)

Tracking

3.0 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686 (x86_64); rv:2.0b3) Gecko/20100805 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (X11; Linux i686 (x86_64); rv:2.0b3) Gecko/20100805 Firefox/3.0.6

I have two soundcard devices loaded (pc-Speaker and the on-board sound card):
daniel@venus:/$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: pcsp [pcsp], device 0: pcspeaker [pcsp]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

In xine, amarok, skype, etc. I can select the output device like this: default:CARD=NVidia

But in Firefox this is not possible. Firefox always uses the first soundcard.
Only if my systems loads the NVidia soundcards first (card 0) I can hear sound. The load order is random at system startup.



Reproducible: Always

Steps to Reproduce:
1. start your linux system with the snd-pcsp first, the onboard soundcard seconds
2. start any flash content site with audio
3. you will hear nothing
4. start your linux system with onboard soundcard first
5. you will hear sound
Actual Results:  
no sound

Expected Results:  
sound

Updated

7 years ago
Version: unspecified → 3.0 Branch

Comment 1

5 years ago
Is this still an issue on current Firefox versions (23,24,25)?
Flags: needinfo?(daniel)
(Reporter)

Comment 2

5 years ago
Sorry, I can't reproduce the original situation anymore. I've started the old linux box sometimes but there are only two soundcards available, but nt the pcspeacker anymore. I think this was fixed with the distribution upgrade. Close the bug, it is too old ...
Flags: needinfo?(daniel)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.