Firefox 4 beta download confirmation page

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: malexis, Assigned: pascalc)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Project Description
Currently there's no way to track successful beta downloads on all locales outside of en-US. All international downloads occur upon download button click - no confirmation page is served. We're in the process of launching multiple paid marketing campaigns to help us reach aggressive Beta downloads (target goal is 2-4M ADUs before release candidate is available). Marketing efforts include an ad campaign, paid search campaign, and the Spread Firefox affiliate program to launch mid-September.

Measuring the effectiveness of these campaigns and providing a good user experience to our Beta users is essential. To do so, we'd like to implement a light-weight "Thank You" page on all international beta download locales.

Page Objectives
1. Provide a better user experience by thanking beta users for downloading beta
2. Remind beta users to provide feedback
3. Enable download tracking, which will allow us to track and optimize paid ad spend, as well as ability to both track and reward "Spread Firefox" affiliate program participants

Technical Requirements

    * By "lightweight" the intent is to have this page contain text only and existing graphics
    * Localize in 39 beta supported locales
    * Use Beta template (not current template shown in mockup)
    * Contain Webtrends tracking code (Laura F. to provide)
    * Use Windows graphics in feedback screenshots


Stakeholders
Laura Mesa - Fx PMM
Mayumi - Fx PMM
NoBox - Ad Agency
Laura Forrest - Marketing Metrics

Timeline
Copy/Mockup - Attached
L10n -  complete 8/30/2010
Pages live: ASAP, or before ad campaign launch date 9/8/2010

Relevant Links
Beta Download Pages:
http://www.mozilla.com/en-US/firefox/beta
http://www.mozilla.com/en-US/firefox/all-beta.html

Comment 1

8 years ago
Created attachment 468433 [details]
Mockup

Adding a mockup of what this page may look like.
(In reply to comment #1)
> Created attachment 468433 [details]
> Mockup
> 
> Adding a mockup of what this page may look like.

Here's the text:

"Thank you for downloading Firefox 4 Beta!
Your download should automatically begin in a few seconds, but if not, _click here_.
Don't forget to give us feedback about the Beta!--click on the Feedback button on the top right corner of your browser to send us your thoughts."
(Assignee)

Updated

8 years ago
Assignee: malexis → nobody
Component: Webdev → www.mozilla.com
Product: mozilla.org → Websites
QA Contact: webdev → www-mozilla-com
(Assignee)

Comment 3

8 years ago
>    * Localize in 39 beta supported locales

We'll likely have more locales by the time you want to go live since we will be probably at beta 5 or 6
(Assignee)

Comment 4

8 years ago
> L10n -  complete 8/30/2010

This is very unlikely, we are August 24, that means that you want the page built, translated and QAed in 40+ locales in less than 6 days, during summer time, while we are also in the middle of the beta 4 release which also means a lot of community work, during summer time when many of our usual localizers are away.
(Reporter)

Updated

8 years ago
Component: www.mozilla.com → Webdev
Product: Websites → mozilla.org
QA Contact: www-mozilla-com → webdev
(Reporter)

Updated

8 years ago
Assignee: nobody → craigcook.bugz
(In reply to comment #4)
> > L10n -  complete 8/30/2010
> 
> This is very unlikely, we are August 24, that means that you want the page
> built, translated and QAed in 40+ locales in less than 6 days, during summer
> time, while we are also in the middle of the beta 4 release which also means a
> lot of community work, during summer time when many of our usual localizers are
> away.

Pascal, do you think you can have the text localized for Sept 6/7th?

Craig, are you just going to go ahead and build the pages, and then slip the localized text in afterwards?
(In reply to comment #5)

> Craig, are you just going to go ahead and build the pages, and then slip the
> localized text in afterwards?

I'm building the basic shell of the page and I'll have to hand it off to another developer (Pascal?) to add in the functional bits to make it localizable (building in the locale detection, hooking it up to Verbatim, etc.). Since it's just one simple page I'm aiming to have my part done by the end of this week. 

So if all goes smoothly it may be ready for localization by the middle of next week, but that still only allows a few days before it's supposed to go live. I think we should identify the top priority locales (whoever does the most downloading) to try to have at least those covered before the 8th and other translations could be added as they're completed.
(In reply to comment #6)
> (In reply to comment #5)
> 
> 
> So if all goes smoothly it may be ready for localization by the middle of next
> week, but that still only allows a few days before it's supposed to go live. I
> think we should identify the top priority locales (whoever does the most
> downloading) to try to have at least those covered before the 8th and other
> translations could be added as they're completed.

Sounds good. From my perspective, the top locales are:
2. Language/Locale Tiers
Tier 1: US,Brazil, Germany, Spain, France
Tier 2: United Kingdom, Russia, Italy, China, Poland
Tier 3: Japan, India, Vietnam, Indonesia, Mexico

Pascal, however, probably has a better sense of what the top locales are, so I'll let him comment.

Comment 8

8 years ago
Please add these three meta tags to each new page so we can track beta download confirmations. 

<META NAME=”WT.si_n” CONTENT=”DownloadFirefox”>
<META NAME=”WT.si_x” CONTENT=”1”>
<META NAME=”WT.si_cs” CONTENT=”1”> 

Additional directions and documentation are available here:
https://intranet.mozilla.org/WebAnalytics#Custom_Conversion_Metrics
(In reply to comment #8)
> Please add these three meta tags to each new page so we can track beta download
> confirmations. 
> 
> <META NAME=”WT.si_n” CONTENT=”DownloadFirefox”>
> <META NAME=”WT.si_x” CONTENT=”1”>
> <META NAME=”WT.si_cs” CONTENT=”1”> 
> 
> Additional directions and documentation are available here:
> https://intranet.mozilla.org/WebAnalytics#Custom_Conversion_Metrics

These should be abstracted into a template file or function, so that we don't duplicate them all over the codebase.  I can help with that.
(Assignee)

Comment 10

8 years ago
I am building the page now (btw, the en-US version of it is quite a mess ;) )

I intend to put it in ab-CD/download/ and not in ab-CD/products/download.html, no need to reproduce a url scheme that dates back to firefox 1.0 when we had a very different file structure.
(In reply to comment #10)
> I am building the page now (btw, the en-US version of it is quite a mess ;) )

Since I'm busy with other projects and wouldn't have been able to start on this until Friday, I'm more than happy to let you take it over if it buys us more time for l10n. Reassigning to you for now. Just let me know if you need a hand with anything.
Assignee: craigcook.bugz → pascalc
(Assignee)

Comment 12

8 years ago
Thanks Craig, I should have the page ready in a few hours and will file bugs tomorrow for locales to start translations. If I have specific questions, I will not hesitate to ping you in the bug :)
(In reply to comment #12)
> Thanks Craig, I should have the page ready in a few hours and will file bugs
> tomorrow for locales to start translations. If I have specific questions, I
> will not hesitate to ping you in the bug :)

Awesome. Also, spoke with Blake and he explained that we just need one page and that the content would dynamically change depending on the locale the user downloads.  From what you wrote above, it sounds like you have everything under control, but I just wanted to put that in there in case. 

Thanks!
(Assignee)

Comment 15

8 years ago
Transition page activated for French in r73046

http://www-trunk.stage.mozilla.com/fr/firefox/beta/
Just spoke with Pascal.  We will remove the the Feedback image and accompanying text from the page--it's too much graphics work for the time we have to get this going. We can tweak the concept later if we want, but right now the thank you message gets the job done. Thanks.
(Assignee)

Comment 18

8 years ago
some restyling + french version done in r73050
(Assignee)

Comment 19

8 years ago
r73057 changes our beeta download box and links library to generate the extra javascript hacks used on en-US to go through IE redirect blocking features
(Assignee)

Comment 20

8 years ago
r73063 also changes all-beta.html to support transition pages
(Assignee)

Comment 21

8 years ago
Tested on Linux/Mac/WinXp/Vista with Firefox/Chrome/IE/Safari/Opera, works fine
(Assignee)

Comment 22

8 years ago
http://www.mozilla.com/fr/firefox/beta/
http://www.mozilla.com/fr/firefox/all-beta.html

Laura, please check that you do get hits recorded in Webtrends for the French locale, thanks.

Comment 23

8 years ago
(In reply to comment #22)
> http://www.mozilla.com/fr/firefox/beta/
> http://www.mozilla.com/fr/firefox/all-beta.html
> 
> Laura, please check that you do get hits recorded in Webtrends for the French
> locale, thanks.

Yes, hits are being recorded on the URLs above. I also see the conversion tag in the code of www.mozilla.com/fr/download.
(Assignee)

Comment 24

8 years ago
I will be filing per locale bugs shortly.
(Assignee)

Comment 25

8 years ago
Laura(f) can you also check that the es-AR locale is having its hits recorded?

http://www.mozilla.com/es-AR/firefox/beta/

Should have at least 1 hit :)
(Assignee)

Comment 26

8 years ago
tracking bug for localization is bug #591217 (21 locales done for now)

Comment 27

8 years ago
(In reply to comment #25)
> Laura(f) can you also check that the es-AR locale is having its hits recorded?
> 
> http://www.mozilla.com/es-AR/firefox/beta/
> 
> Should have at least 1 hit :)

Yes, hits are being recorded.
(Assignee)

Comment 28

8 years ago
FYI, we now have 39 locales having a transition page tracked on mozilla.com for beta downloads.
(Reporter)

Comment 29

8 years ago
Is it OK to close this?

Comment 30

8 years ago
I believe it's okay to close. 

Pascal, can you confirm?
(Assignee)

Comment 31

8 years ago
nope, we have new locales added with each beta release and this page will be reused for stability releases in the future, we will close the bug once we have our 80+ locales done :)
(Assignee)

Comment 32

6 years ago
The translation done for all locales we ship as of today except a couple of unmaintained locales we will probably drop at some point (Mongolian, Georgian, Tamil). marking fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.