The default bug view has changed. See this FAQ.

Notifications don't work in the sidebar

RESOLVED FIXED

Status

SeaMonkey
Sidebar
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey2.0.9, regression})

Trunk
fixed-seamonkey2.0.9, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
At some point, probably soon after we implemented notifications, since I know I would have tested it at the time, and it fails in an old 2.0pre/Gecko1.9.1pre build, the <browser> element got changed such that it now has a non-null docShell property even when it is hidden.

This means that notifications in the sidebar don't actually work :-(

Steps to reproduce problem:
javascript:sidebar.addPanel('Popup Test', 'http://www.popuptest.com/popuptest1.html', null);
(Assignee)

Comment 1

7 years ago
Created attachment 468444 [details] [diff] [review]
Proposed patch

I also took the opportunity to move the button(s) between the icon and the close button. This often saves space in the common case, and I used an arrowscrollbox to stop the sidebar looking too bad in the multiple button case. Geolocation is a particularly bad example, try the following:

javascript:sidebar.addPanel("Demo: geolocation", "http://html5demos.com/geo", null);

(note that this "works" in the sidebar without the patch, because the geolocation notification code accesses the notificationbox directly.)
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #468444 - Flags: review?(iann_bugzilla)

Comment 2

7 years ago
Comment on attachment 468444 [details] [diff] [review]
Proposed patch

r=me
Attachment #468444 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

7 years ago
Attachment #468444 - Flags: approval-seamonkey2.0.7?
(Assignee)

Comment 3

7 years ago
Pushed changeset 262c8f5ec24d to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 4

7 years ago
Comment on attachment 468444 [details] [diff] [review]
Proposed patch

I'm pretty sure we don't have any add-ons or such hooking into sidebar notifications, but else the <binding> change wouldn't be too good on a stable branch. In this case, I guess it's OK.
Attachment #468444 - Flags: approval-seamonkey2.0.7? → approval-seamonkey2.0.7+

Comment 5

7 years ago
Comment on attachment 468444 [details] [diff] [review]
Proposed patch

2.0.7 has been shipped, transferring approval to 2.0.8 instead.
Attachment #468444 - Flags: approval-seamonkey2.0.7+ → approval-seamonkey2.0.8+
(Assignee)

Comment 6

7 years ago
Pushed changeset e1bb865fb450 to releases/comm-1.9.1
Keywords: fixed-seamonkey2.0.8
You need to log in before you can comment on or make changes to this bug.