whitespace after closing noscript tag needed

VERIFIED FIXED in mozilla0.8

Status

()

Core
HTML: Parser
P3
minor
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Johannes la Poutre, Assigned: harishd)

Tracking

({dataloss, testcase})

Trunk
mozilla0.8
x86
All
dataloss, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Fix in hand, URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
If in html content the noscript element is used, all content which is on the
same line in the source as a closing noscript tag, is suppressed from rendering
unless there is a whitespace character between the closing noscript tag and the
following content.

This behaviour started somewhere during the second half of the October builds on
all platforms I could test.

See url for a test case.

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss, testcase
(Assignee)

Comment 1

17 years ago
Created attachment 20365 [details] [diff] [review]
Proposed patch v1.1
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: Fix in hand
(Reporter)

Updated

17 years ago
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.8
(Assignee)

Comment 2

17 years ago
Created attachment 24624 [details] [diff] [review]
patch v1.2 [ r=jst sr=vidur]
(Assignee)

Comment 3

17 years ago
Fix is in. Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
updated qa contact.
QA Contact: janc → bsharma

Comment 5

17 years ago
Verified on:
build: 2001-06-04-09-Mtrunk
platform: WinNT

The test case renders fine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.