Crash of Quicktime plugin in [@ hang | ntdll.dll@0x200ed ]

RESOLVED WORKSFORME

Status

Plugins Graveyard
QuickTime (Apple)
--
critical
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

x86_64
Windows 7

Details

(URL)

(Reporter)

Description

8 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre

No problem in FF 4.0 b4

Quicktime plugin version : 7.6.7
http://crash-stats.mozilla.com/report/index/bp-0ab0befd-11a3-4a21-b4a8-026172100823
Signature	hang | ntdll.dll@0x200ed
UUID	0ab0befd-11a3-4a21-b4a8-026172100823
Process Type	plugin Version: Filename: npqtplugin.dll
Time 	2010-08-23 13:54:11.904348
Uptime	170
Install Age	15352 seconds (4.3 hours) since version was first installed.
Product	Firefox
Version	4.0b5pre
Build ID	20100823055515
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x77a200ed

Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	ntdll.dll@0x200ed 	
1 	kernel32.dll 	kernel32.dll@0x1162c 	
2 	user32.dll 	RealMsgWaitForMultipleObjectsEx 	
3 	user32.dll 	MsgWaitForMultipleObjects 	
4 	xul.dll 	mozilla::ipc::RPCChannel::WaitForNotify 	ipc/glue/WindowsMessageLoop.cpp:887
5 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:201
6 	xul.dll 	mozilla::plugins::PPluginScriptableObjectChild::CallInvoke 	obj-firefox/ipc/ipdl/PPluginScriptableObjectChild.cpp:212
7 	xul.dll 	mozilla::plugins::PluginScriptableObjectChild::ScriptableInvoke 	dom/plugins/PluginScriptableObjectChild.cpp:158
8 	xul.dll 	mozilla::plugins::child::_invoke 	dom/plugins/PluginModuleChild.cpp:1197
9 	QuickTimeWebHelper.qtx 	QuickTimeWebHelper.qtx@0x16b07

QuickTimeVR.qtx  	7.67.75.0  	C653F534ACE74D459B4368E88844B3851  	QuickTimeVR.pdb
QuickTimeStreamingExtras.qtx 	7.67.75.0 	3CD2508E379C4B9FAED80D1A1CDB14B11 	QuickTimeStreamingExtras.pdb
QuickTimeStreamingAuthoring.qtx 	7.67.75.0 	BF5238F9BE054E3CA1EB742AB3C0D3941 	QuickTimeStreamingAuthoring.pdb
QuickTimeStreaming.qtx 	7.67.75.0 	73667E7522FF4856ADF2A42E2823A1B81 	QuickTimeStreaming.pdb
QuickTimeMusic.qtx 	7.67.75.0 	DA315362479C4E00A7DD06AE32F5975C1 	QuickTimeMusic.pdb
QuickTimeMPEG4Authoring.qtx 	7.67.75.0 	EE43CDAF7007430195489C2CFD7752771 	QuickTimeMPEG4Authoring.pdb
QuickTimeMPEG4.qtx 	7.67.75.0 	80AEDA3CBF6048A1A46F931E4F34C5851 	QuickTimeMPEG4.pdb
QuickTimeMPEG.qtx 	7.67.75.0 	94BA61F45CA341CBB04CCFEFD145DC9D1 	QuickTimeMPEG.pdb
QuickTimeInternetExtras.qtx 	7.67.75.0 	95779A56F34846EDB37BDBD909556AA81 	QuickTimeInternetExtras.pdb
QuickTimeImage.qtx 	7.67.75.0 	A3714F49994248D7A7B9363BEB9BBEC61 	QuickTimeImage.pdb
QuickTimeH264.qtx 	7.67.75.0 	FD975D99D98F46B4B37F3F4673F8964B1 	QuickTimeH264.pdb
QuickTimeAuthoring.qtx 	7.67.75.0 	6840043452B44D5D83D48EAC56DDB8BE1 	QuickTimeAuthoring.pdb
QuickTime.qts 	7.67.75.0 	9A878B36B6FB461EA8EA8C4D8B3B01B81 	QuickTime.pdb
QuickTimeEssentials.qtx 	7.67.75.0 	33B1170BB7A045E29D507DDD72C0EA961 	QuickTimeEssentials.pdb
QuickTimeEffects.qtx 	7.67.75.0 	B1D54F648297441985AD0EBA045989841 	QuickTimeEffects.pdb
QuickTimeCapture.qtx 	7.67.75.0 	5AAF065A7F47453C9AB6FEA4D5B981471 	QuickTimeCapture.pdb
CoreAudioToolbox.dll 	7.9.3.0 	195A477825574BF3B3BCE08F9FFA06F51 	CoreAudioToolbox.pdb
QuickTimeAudioSupport.qtx 	7.9.2.0 	4813D6C65DCC42E5AF0BE31075DB5A701 	QuickTimeAudioSupport.pdb
QuickTime3GPPAuthoring.qtx 	7.67.75.0 	CD378C4614944725B93EA8BA4C4105381 	QuickTime3GPPAuthoring.pdb
QuickTime3GPP.qtx 	7.67.75.0 	4C6B289C14BB4B4386718157C13C238E1 	QuickTime3GPP.pdb
QuickTimeWebHelper.qtx  	7.6.7.0  	8C2337246DB04AEBB944C9A39295BE861  	QuickTimeWebHelper.pdb
QTCF.dll  	7.67.75.0  	1A29241B36FE4465A5BC494DA16FE10F1  	QTCF.pdb
npqtplugin.dll  	7.6.7.0  	AEB78183B45040D786B08C5C1191C0991  	npqtplugin.pdb


It crashes also with the previous version :
Quicktime plugin version : 7.6.6
http://crash-stats.mozilla.com/report/index/bp-0e294e81-3c53-458d-a31f-3ae222100823

Comment 1

8 years ago
The plugin appears to be calling back to the browser in response to a request by the browser....

Signature	hang | mozilla::plugins::PPluginScriptableObjectParent::CallHasProperty(mozilla::plugins::PPluginIdentifierParent*, bool*)
UUID	a5e34397-af32-4475-af0b-424342100823
Time 	2010-08-23 13:54:38.631612
Uptime	198
Install Age	15352 seconds (4.3 hours) since version was first installed.
Product	Firefox
Version	4.0b5pre
Build ID	20100823055515
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x703fc162
User Comments	
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
6 	xul.dll 	CrashReporter::CreatePairedMinidumps 	toolkit/crashreporter/nsExceptionHandler.cpp:1831
7 	xul.dll 	mozilla::plugins::PluginModuleParent::ShouldContinueFromReplyTimeout 	dom/plugins/PluginModuleParent.cpp:242
8 	xul.dll 	mozilla::ipc::SyncChannel::ShouldContinueFromTimeout 	ipc/glue/SyncChannel.cpp:261
9 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:210
10 	xul.dll 	mozilla::plugins::PPluginScriptableObjectParent::CallHasProperty 	obj-firefox/ipc/ipdl/PPluginScriptableObjectParent.cpp:288
11 	xul.dll 	mozilla::plugins::PluginScriptableObjectParent::ScriptableHasProperty 	dom/plugins/PluginScriptableObjectParent.cpp:312
12 	xul.dll 	NPObjWrapper_NewResolve 	modules/plugin/base/src/nsJSNPRuntime.cpp:1654
13 	xul.dll 	CallResolveOp 	js/src/jsobj.cpp:4323
14 	xul.dll 	NewShortString 	js/src/jsstr.cpp:3333
15 	xul.dll 	js_GetProperty 	js/src/jsobj.cpp:4839
16 	xul.dll 	JSObject::getProperty 	js/src/jsobj.h:713
17 	xul.dll 	JS_GetUCProperty 	js/src/jsapi.cpp:3664
18 	xul.dll 	GetProperty 	modules/plugin/base/src/nsJSNPRuntime.cpp:607
19 	xul.dll 	doInvoke 	modules/plugin/base/src/nsJSNPRuntime.cpp:675
20 	xul.dll 	nsJSObjWrapper::NP_Invoke 	modules/plugin/base/src/nsJSNPRuntime.cpp:747
21 	xul.dll 	mozilla::plugins::parent::_invoke 	modules/plugin/base/src/nsNPAPIPlugin.cpp:1527
22 	xul.dll 	mozilla::plugins::PluginScriptableObjectParent::AnswerInvoke 	dom/plugins/PluginScriptableObjectParent.cpp:787
23 	xul.dll 	mozilla::plugins::PPluginScriptableObjectParent::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginScriptableObjectParent.cpp:771
24 	xul.dll 	mozilla::plugins::PPluginModuleParent::OnCallReceived 	obj-firefox/ipc/ipdl/PPluginModuleParent.cpp:596
25 	xul.dll 	mozilla::ipc::RPCChannel::DispatchIncall 	ipc/glue/RPCChannel.cpp:510
26 	xul.dll 	mozilla::ipc::RPCChannel::Incall 	ipc/glue/RPCChannel.cpp:496
27 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:310
28 	xul.dll 	mozilla::plugins::PBrowserStreamParent::CallNPP_StreamAsFile 	obj-firefox/ipc/ipdl/PBrowserStreamParent.cpp:103
29 	xul.dll 	mozilla::plugins::BrowserStreamParent::StreamAsFile 	dom/plugins/BrowserStreamParent.cpp:137
30 	xul.dll 	mozilla::plugins::PluginModuleParent::NPP_StreamAsFile 	dom/plugins/PluginModuleParent.cpp:482
31 	xul.dll 	nsNPAPIPluginStreamListener::OnFileAvailable 	modules/plugin/base/src/nsNPAPIPluginStreamListener.cpp:752
32 	xul.dll 	nsPluginStreamListenerPeer::OnFileAvailable 	modules/plugin/base/src/nsPluginStreamListenerPeer.cpp:1218
33 	xul.dll 	nsPluginStreamListenerPeer::OnStopRequest 	modules/plugin/base/src/nsPluginStreamListenerPeer.cpp:1043
34 	xul.dll 	nsHttpChannel::OnStopRequest 	netwerk/protocol/http/nsHttpChannel.cpp:3658
35 	xul.dll 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:578
36 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:403
37 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:112
38 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
39 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
40 	xul.dll 	xul.dll@0xb8bce3 	
41 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219
42 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
43 	xul.dll 	_SEH_epilog4 	
44 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
45 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:175
(Reporter)

Comment 2

6 years ago
With Fx 8 and QT 7.7.1, I can no longer reproduce.
In addition, there have been no crashes with this crash signature for the last four weeks across all versions.
I close it as WFM.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.