need to transfer popupnotifications when tearing off tabs (geolocation notification disappears once tab is turned into a window)

RESOLVED DUPLICATE of bug 723951

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 723951
8 years ago
7 years ago

People

(Reporter: u88484, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [doorhanger][good first bug][mentor=gavin][lang=js])

(Reporter)

Description

8 years ago
The geolocation doorhanger notification requires the page to be reloaded to show again once tab is reordered or the tab has been dragged to the content area to create a new window out of that tab.

STR:
1) http://benwerd.com/lab/geo.php
2) Drag tab to content area to create a new window out of the tab
3) The geolocation doorhanger notification and icon have disappeared

The page has to be reloaded to invoke the notification again or else the user is left clueless on why the page keeps telling the user that it is waiting on the browser.
(Reporter)

Comment 1

8 years ago
Requesting blocking and also forgot to say that this does not happen if the tab order is changed on the tabbar.  The notification icon still correctly displays.
blocking2.0: --- → ?
Assignee: nobody → gavin.sharp
blocking2.0: ? → betaN+
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Geolocation doorhanger notification requires page to be reloaded to show again once tab is turned into a window → need to transfer popupnotifications when tearing off tabs (geolocation notification disappears once tab is turned into a window)
Hmm, this actually affects the notification bars too. Odd that no one noticed with those...
I think that makes this not a blocker. Probably still worth fixing, though.
blocking2.0: betaN+ → -
(In reply to comment #0)
> The geolocation doorhanger notification requires the page to be reloaded to
> show again once tab is reordered

And just to be clear, I don't think this applies to tab reordering. That part works for me.
Whiteboard: [doorhanger]
Assignee: gavin.sharp → nobody
Whiteboard: [doorhanger] → [doorhanger][good first bug][mentor=gavin]

Updated

7 years ago
Whiteboard: [doorhanger][good first bug][mentor=gavin] → [doorhanger][good first bug][mentor=gavin][lang=js]
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 723951
You need to log in before you can comment on or make changes to this bug.