Closed Bug 590001 Opened 11 years ago Closed 11 years ago

JM+TM: shell and browser jstest failure on js1_5/extensions/regress-348986.js

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dmandelin, Assigned: dmandelin)

References

Details

Attachments

(1 file)

$ python ../tests/jstests.py -j8 shell/js -so 348986
c:\sources\jaegermonkey\js\src\debug\shell\js -m -j -f shell.js -f js1_5\shell.js -f js1_5\extensions\shell.js -f ./js1_5\extensions\regress-348986.js
    rc = 3, run time = 0.103000
BUGNUMBER: 348986
STATUS: Recursion check of nested functions
./js1_5\extensions\regress-348986.js:65: InternalError: too much recursion
REGRESSIONS
    js1_5\extensions\regress-348986.js
FAIL
Assignee: general → dmandelin
Attached patch PatchSplinter Review
One-character fix, with giant comment explaining the problem and my assumptions in thinking this solution is correct.
Attachment #468570 - Flags: review?(dvander)
Comment on attachment 468570 [details] [diff] [review]
Patch

Nice find. Thanks for the detailed explanation.
Attachment #468570 - Flags: review?(dvander) → review+
Duplicate of this bug: 590002
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 590255
Duplicate of this bug: 590254
You need to log in before you can comment on or make changes to this bug.