delete key does not empty trash

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
18 years ago
8 years ago

People

(Reporter: st8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
delete key does not empty trash
can you explain this better?

do you mean, "when I've got the trash folder selected, delete should empty it?"

if you had the folder pane selected, but the thread pane had focus, delete
should (and does) delete the message.

please elaborate.  moving to "Mail Window Front End"
Component: Account Manager → Mail Window Front End
(Reporter)

Comment 2

18 years ago
Sorry...

If I highlight messages in the trash folder and press delete, I'm used to
them being deleted.

Also, if I highlight the trash folder and press delete I expect the
folder to be deleted.
When I highlight messages in the trash folder and hit delete, they are deleted.
If I do that to the folder, all the messages in it are deleted but the folder
itself is not.  (linux trunk 2000110908)

Is that the behavior you are seeing?  If not, are you seeing the problem with a
recent build? 
I'm going to WORKSFORME on  this bug, feel free to re-open (reporter) if you
feel this is an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Marking VERIFIED FIXED (WORKSFORME)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
What I was trying to explain (badly!) is:

When I focus the trash folder on the left hand pane (the folder list), and press
the delete key, I would want to delete the entire contents of the trash folder.

Did you intend to have this feature?
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
This used to work for me with the 1109 build, but no longer works in
2000-12-05-08.  That is, highlighting the folder and hitting delete does not
empty the trash.
Confirming, OS -> All
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
I'm not sure what behavior we want, I'll pin it down.
QA Contact: esther → stephend

Comment 10

18 years ago
behavior still observed in 2001030605 on Win 98

Comment 11

17 years ago
This is a nifty feature, that I would like to see - but note, it is a feature, 
and I don't think it is spec-ed, so making this a RFE.
Severity: normal → enhancement
I find this to a be a really cumbersome issue (on both Mac/PC platforms).  An
enhancement to fix this would realy be of help.

btw:  this should be All platforms.
Exact, and be carefull on Mac there is two delete key (Backspace and Delete)
See bug 57510
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
Priority: P3 → --
QA Contact: stephend → message-display

Comment 14

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 15

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 17

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 19

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 20

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago9 years ago
Resolution: --- → EXPIRED

Comment 21

8 years ago
Deleting only the folder *contents* instead of the usual and expected deletion of the entire folder itself just because it's the special folder 'Trash' would just be confusing => WONTFIX.
Resolution: EXPIRED → WONTFIX
You need to log in before you can comment on or make changes to this bug.