"Issues" on site filter is a 404

VERIFIED FIXED in 1.7

Status

Input
General
P1
major
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: stephend, Assigned: wenzel)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
1. Load http://input.stage.mozilla.com/en-US/site/http/1001bouquins.free.fr
2. Click on "Issues"

Actual:

404
(Assignee)

Comment 1

8 years ago
Oh, looks like I went trigger-happy on the 404ing there. Presumably, it throws a 404 when there are no results.
Assignee: nobody → fwenzel
Priority: -- → P1
(Assignee)

Comment 2

8 years ago
CCing mkurze: Michael, would it be the right fix for this to generate an empty sites cluster if no positive results exist? The current problem is that we get a 404 because indeed there is nothing in the database for this site and "Issues only". So if I wanted to fix this on my end, I would need to do some sort of fallback along the lines of, "if you didn't find anything check if this URL exists *at all* in the database, and only if not throw a 404, otherwise pretend you found an empty list of clusters".
The way the generate script currently works, it is actually pretty difficult to generate such empty sites. I would have to change it in a significant way, as currently everything is generated bottom up (from the opinions that actually are in the db) rather than top down (from the urls, versions and such). I don't think that would be a good thing to do two days before release.

So I know that is not really pretty but like you suggested, either hit the db once more to check if a 404 is warranted, or to just always happily return an empty result set, like the main dashboard search does when you look up a non-existing URL.
(Assignee)

Comment 4

8 years ago
(In reply to comment #3)
> So I know that is not really pretty but like you suggested, either hit the db
> once more to check if a 404 is warranted, or to just always happily return an
> empty result set, like the main dashboard search does when you look up a
> non-existing URL.

So be it. Better than an unwarranted 404.

http://github.com/fwenzel/reporter/commit/ef3bef8
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

8 years ago
Verified FIXED.
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input

Updated

6 years ago
Duplicate of this bug: 720010
You need to log in before you can comment on or make changes to this bug.