Copy to Sent folder fails silently

VERIFIED FIXED

Status

MailNews Core
Composition
P3
critical
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: BenB, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-])

(Reporter)

Description

18 years ago
Reproducable: Intermittendly. Now appears since some hours - restarting Mozilla
didn't help.
Build: N6.0 branch from 2000-11-01.

I have the "Sent" folder on the UW-IMAP server. Sometimes, no copy of the sent
msg is saved.

This is severe dataloss for me. DOGFOOD.
(Reporter)

Comment 1

18 years ago
Nominating for rtm, so PDT knows about this, even though we can probably not do
much about it without more info. Pessimistically adding relnoteRTM, too.

Can I do anything to give more info? I have no debug builds, but both branch and
trunk builds. Using Linux.
Keywords: dogfood, relnoteRTM, rtm
(Reporter)

Comment 2

18 years ago
> Now appears since some hours

To clarify: Since some hours, *no* msg is saved.

I also have problems with SaveAsDraft - sometimes, it just won't save (no error,
nothing).

Comment 3

18 years ago
Not putting in release notes. Too vague.
Keywords: relnoteRTM

Comment 4

18 years ago
Changed summary for readability.

Ben, your message _did_ get sent though - right?
Summary: Send copy fails silently → Copy to Sent folder fails silently
Whiteboard: [need info]
(Reporter)

Comment 5

18 years ago
I think so, but I am not sure. Bug disappeared again, so I cannot test right now.

Comment 6

18 years ago
recommend release noting this unless we have evidence that this is happening on
all servers.  We could also release note that copy to sent needs to be a local
folder.
(Reporter)

Comment 7

18 years ago
ducarroz, jefft, bienvenu, if I can try anything that will help to narrow down
the problem and provide a more specific relnote (or even help fixing it), tell
me what I should do.
The IMAP logging works even on optimized buils (I have no debug ones), right?

Comment 8

18 years ago
Bug 57614 may have fixed this one. Ben, imap logging works for release build
too. To see copy to sent folder works search for "append command" in the log
after delivered the message. 

Comment 9

18 years ago
rtm-, not stop ship.  Adding relnoteRTM in case the note should be made.  Seems
like we're saying this is a WFM though.
Keywords: relnoteRTM
Whiteboard: [need info] → [rtm-]
(Reporter)

Comment 10

18 years ago
Since the day after I filed this bug, I havn't seen the bug again, but I didn't
send many mails using Mozilla either. I have IMAP:5 in my Mozilla start script
now, in case it appears again.
(Assignee)

Comment 11

18 years ago
I've just checked in a fix (2 nights ago) for what I think is the last point
where we fail to report an error during the send.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Verified on trunk build 2000121209, Linux.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.